运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

路由技术

运维开发网 https://www.qedev.com 2021-04-22 11:05 出处:51CTO 作者:CHENG791
路由技术 静态路由及缺省路由 动态路由RIP协议 动态路由OSPF协议 策略路由 路由更新操纵 路由重分布 访问控制列表、基于时间访问控制列表、专家级访问控制列表 PPTP ***、IPSec ***、L2TP *** 静态路由及缺省路由:ip route 目标网段 目标网段掩码 出接口 下一跳地址

路由技术

静态路由及缺省路由

动态路由RIP协议

动态路由OSPF协议

策略路由

路由更新操纵

路由重分布

访问控制列表、基于时间访问控制列表、专家级访问控制列表

PPTP ***、IPSec ***、L2TP ***


 

 

静态路由及缺省路由:ip route 目标网段 目标网段掩码 出接口 下一跳地址

例子:静态路由:ip  route  192.168.1.0  255.255.255.0  f0/0  192.168.10.254

  缺省(默认)路由:ip   route 0.0.0.0  0.0.0.0  192.168.10.254

  浮动路由:ip route  192.168.1.0  255.255.255.0  192.168.10.254  50

 


 

动态路由RIP协议:

配置:

router rip

  version 2 

  network 192.168.1.0

  no auto-summary

认证方式:接口下配置

 


 

 

动态路由OSPF协议:

配置:

router ospf 100

  router-id 1.1.1.1

  network 192.168.1.0 0.0.0.255 area 0

配置特殊区域:

STUB(NSSA和STUB)标志位不相同(路由进程下:area 1 ?)

路由技术

认证方式:接口下配置

 


 

 

ACL:http://www.cnblogs.com/tcheng/p/5943951.html

 


 

 

策略路由:

1.定义ACL

2.创建router-map

  2.1、匹配流量

  2.2、对匹配的流量进行处理

配置(例子):

access-list 10 permit 192.168.1.0

router-map TEST permit 5

  match ip address 10

  set tag 24

 

应用:例子(重分布)

redistribute eigrp 90 subnets router-map TEST

 


 

 

路由技术

 

5.应用:进入接口:crypto map CTC

 

****************************************************************************

L2TP:

实验拓扑:

路由技术

配置实例:

R1:

基本配置

conf t

in f0/0

ip add 10.0.0.1 255.255.255.0

no sh

exit

in s0/0

ip add 200.0.0.5 255.255.255.252

clock rate 9600

no sh

exit

ip routing

ip route 0.0.0.0 0.0.0.0 200.0.0.6

L2TP配置

username user1 password 0 user123456 ------------ 创建用户和密码

vpdn enable  ------------------------------------ 开启L2TP

vpdn-group myl2tp  ------------------------------ 创建组

accept-dialin ----------------------------------- 服务器接收拨入

protocol l2tp ----------------------------------- 指定L2TP协议

Virtual-template 1 ------------------------------ 创建虚拟接口模板

exit -------------------------------------------- 返回上一层(exit)

no l2tp tunnel authentication  ------------------ 关闭隧道认证

exit

interface Virtual-template1  -------------------- 进入虚拟接口模板

ip unnumbered f0/0 ------------------------------ 配置IP地址

encapsulation ppp ------------------------------- 封装PPP  

peer default ip address pool l2tp-user  --------- 设置用户IP地址

ppp authentication chap  ------------------------ 设置认证

exit

ip local pool l2tp-user 10.0.0.50 10.0.0.59 -----设置用户地址池

end

show ip int br

show ip route

---------------------------

R2:

基本配置

conf t

in f0/0

ip add 20.0.0.1 255.255.255.0

no sh

exit

in s0/0

ip add 200.0.0.6 255.255.255.252

clock rate 9600

no sh

exit

ip routing

ip route 0.0.0.0 0.0.0.0 200.0.0.5

exit

show ip int br

show ip route

-------------------------------------------

window客户端设置。

要向WINDOW添加ProhibitIpsec注册表值,请按照下列步骤操作:

1.单击“开始”,单击“运行”,键入regedit,然后单击“确定”。

2.找到下面的注册表子项,然后单击它:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters

3.在该项中新建一个“DWORD值”。

4.将该值名称修改为“ProhibitIpsec”

5.双击该值,将Value data修改为“1”,然后单击“确定”

6.退出注册表编辑器,然后重新启动计算机。

拨号进入网络

 

总结:

1.创建用户和密码

2.开启L2TP

3.创建组

4.服务器接收拨入

5.指定L2TP协议

6.创建虚拟接口模板

7.返回上一层(exit)

8.关闭隧道认证

1.进入虚拟接口模板//interface Virtual-template1

2.配置IP地址      //ip unnumber f0/0

3.封装PPP         //encapsulation ppp

4.设置用户IP地址  //peer default ip address pool l2tp-user

5.设置认证        //ppp authentication chap

6.设置用户地址池  //ip local pool l2tp-user 10.0.0.50 10.0.0.59

 


 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消