运维开发网

CISCO 2900 路由器E1模块配置指南

运维开发网 https://www.qedev.com 2020-12-01 10:21 出处:51CTO 作者:tuolzb
E1端口配置在Cisco2900,4500,4700,7000和7500系列里面均支持E1(2.048Mbps)数率的接口.每一个E1端口可以按时隙分成30路64K数据线路和2路信号线路.这30个64K数据线路每一路均可以当作一条64K的专线.路由器新安装E1板卡后,需要进行配置后才能showrun看到板卡信息,否则是看不到新装的板卡和接口配置命令:Conftcardtypee100:板卡槽位号c

E1端口配置

在Cisco 2900, 4500,4700,7000和7500系列里面均支持E1(2.048Mbps)数率的接口.每一个E1端口可以按时隙分成30路64K数据线路和2路信号线路.这30个64K数据线路每一路均可以当作一条64K的专线.

路由器新安装E1板卡后,需要进行配置后才能show run 看到板卡信息,否则是看不到新装的板卡和接口

配置命令:

Conf t

card type e1 0 0 :板卡槽位号

controller E1 0/0/0

channel-group 0 unframed -非成帧模式

controller E1 0/0/1

channel-group 0 timeslots 1-31--成帧模式

然后在端口下配置IP地址 再show run 会显示

interface Serial0/0/0:0

ip address 192.168.10.2 255.255.255.252

!

interface Serial0/0/1:0

no ip address

业务调试注意事项:

1、电信外线安装完成后要进行打环测试,保障机柜--电信机房端线路正常,无丢包

2、安装配置E1板卡 ,配置未完成前,板卡是不亮灯的

3、注意电信局端给光端机的数据是成贞模式还是非成帧模式,现机房用的是非成帧模式。

配置命令:

1.在配置模式下,定义Controller E1

controller e1 slot/port slot/port----区分槽口号和端口号.

2.定义line code

linecode {ami |hdb3} linecode----默认是HDB3.

3.定义字符帧

framing {crc4 |no-crc4} framing----默认是crc4,要与电信局参数匹配.

4.定义E1组

channel-group number timeslots range [speed {48| 56| 64}]--channel-group----每个E1可以分成30个channel-group,把channel-group和时间槽对应起来.channel-group是0-30,timeslots是1- .

5.指定串口属于那一个channel-group组

interface serial slot/port:channel-group :interface serial----在定义完E1 channel-group后,我们把group赋予成一个虚拟串口.

Channelized E1 Interface Example

配置实例:

1、假设是7500系列路由器,E1接口(MIP板)在插槽4上面.

一个channel-group可对应多个时间槽,本例中serial4/0:1有564Kbps的数率

.具体配置过程如下:

Router#conf t

Router(config)#controller e1 4/0

Router(config-controller)#

Router(config-controller)#framing NO-CRC4

Router(config-controller)#channel-group 0 timeslots 1

(配置时隙1 为channel-group 0,即channel-group 0包含时隙1,它的带

宽就为64K)

Router(config-controller)#channel-group 1 timeslots 2,7-9,20

(配置时隙2,7,8,9,20为channel-group 1,它的带宽就为645=512K,在

这里7-9是指一个段,可以采用同样的命令配置多个channel-group,但需注意

channel-group对应不同的数字,而且一个时隙不能包含在多个组当中)

Router(config-controller)#exit

Router(config)#interface s4/0:0

Router(config-if)#ip address 16.217.30.2 255.255.255.252

Router(config-if)# encapsulation ppp

Router(config-if)#exit

Router(config)#interface Serial4/0:1

Router(config-if)# ip address 16.205.30.5 255.255.255.252

Router(config-if)# encapsulation ppp

(上述过程基本完成E1配置,现只需将相应端口no shut,然后保存配置即可)

下面是配置完成后关于e1的相应配置显示

Configuration for Router:

controller E1 0

framing NO-CRC4

channel-group 0 timeslots 1

channel-group 1 timeslots 2,7-9,20

!

interface Serial4/0:0

ip address 16.217.30.2 255.255.255.252

encapsulation ppp

!

interface Serial4/0:1

ip address 16.205.30.5 255.255.255.252

encapsulation ppp

首先我想先说一下关于E1和CE1的基本概念,E1最本来的用法是在用作语音交换机的数字中继时,是把一条E1作为32个64K来用,但是时隙0和时隙15是传输控制信令用,所以一条E1可以传30路话音。这是在接入服务器上(如华为8010,北电的CVX1800等)说的E1,而和通常在路由器上说的E1概念有些不一样。在路由器上的E1是不能划分时隙的,只能做2M线使用。

  

  CE1的传输线路的带宽是2048K,它和E1的区别主要在于:E1不能划分时隙,CE1能划分时隙。CE1的每个时隙是64K,一共有32个时隙,在使用的时候,可以划分为n*64K,例如:128K,256K等等。CE1的0和15时隙是不用来传输用户的数据流量,0时隙是传送同步号,15时隙传送控制信令,这样实际能用的只有30个时隙,所以在具体配置CE1划分时隙时,要注意些了。CE1 和E1 也可以互联,但是CE1必须当E1来使用,即不可分时隙使用。 因为CE1比较灵活,所以我们能常常碰到CE1。

  

  在路由器配置E1和CE1过程中,我们遇见线路问题的时候会常常会使用show controller e1命令,下面就是show controller e1的详解,希望对各位有些帮助。在说明show controller e1命令后面附上cisco解决E1和CE1故障的流程图!

  

注意问题:在配置CE1的两端路由器上,下面几个参数必须保持一致。它们是:时隙,framing ,linecode ,CRC等,另外还有注意时钟保持同步。

E1 状态查询命令

  

  show controller e1命令的作用

  

  ? 查看关于E1链路的状态。如果你具体指定了slot和port ( 如:show controller e1 5/6),那么显示的是每15分钟的link状态。

  

  ? 能显示用来troubleshoot物理层和数据链路层的信息

  

  ? 本地和远端的告警信息

  

  命令输出的参数描述

  

  先看一下show controller e1的命令输出,下面是两个不同的路由器输出的结果:

  

  7026#show controller e1

  

  E1 5/1 is up。

  

  Applique type is Channelized E1 - balanced

  

  No alarms detected。

  

  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line。

  

  International Bit: 1, National Bits: 11111

  

  Data in current interval (648 seconds elapsed):

  

  0 Line Code Violations, 0 Path Code Violations

  

  0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

  

  0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  

  Total Data (last 24 hours)

  

  0 Line Code Violations, 0 Path Code Violations,

  

  0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

  

  0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  

  

  参数的解释:

  

  域 描述

  

  E1 5/1 is up

  

  显示E1 controller 5/1 正在运行。 E1 controller可能是这三种情况:up, down, administratively down。 另外,如果打环,可以分为本地环和远端环。

  

  Applique Type

  

  指示E1是平衡还是非平衡的,平衡的阻抗是120欧姆,非平衡的是75欧姆

  

  Framing

  

  当前帧类型,缺省的是CRC4,还有 NO-CRC4。

  

  Line Code

  

  当前的线路编码,缺省是:HDB3。 还有ami。

  

  No alarms detected

  

  警告显示。 可能的警告有:

  

  传输者发送远端告警

  

  传输者正发送高警指示信息。

  

  接收者有信号丢失

  

  接收者得到AIS。

  

  接收者有帧丢失。

  

  接收者有远端告警

  

  接收者没有告警

  

  rrent interval

  

  (251 seconds elapsed)

  

  显示当前的累积时间,每隔15分钟刷新一次。

  

  Line Code Violations

  

  指示发生 Bipolar Violation (BPV) 或者Excessive Zeros (EXZ) 错误事件。

  

  Path Code Violations

  

  指示有一个帧同步错误位在D4和E1-no CRC 格式, 或者一个 CRC 错误在扩展的超级帧 Extended Superframe (ESF)和 E1-CRC 格式。

  

  Slip secs

  

  指示DS1帧有效负荷位的复制和删除。 当相连收发两端的路由器不一致的情况,会出现Slip secs

  

  Fr loss secs

  

  一个丢失帧发现的积累时间。

  

  Line Err secs

  

  当一个或多个 Line Code Violation errors发现积累的时间

  

  Degraded mins

  

  一个退化的时间(degraded minute)是被评估的错误率在1E-6和 1E-3之间 的时间

  

  Errored secs

  

  在 ESF 和E1 CRC 链路, 它是指下面之一的错误被探测到的时间:

  

  一个或多个Path Code Violations。

  

  一个或多个Controlled Slip events。

  

  对 SF and E1 no-CRC链路, Bipolar Violations 存在的时间。

  

  Bursty Err secs

  

  多于一个但是小于320个 Path Coding Violation错误, 不是 Severely Errored Frame 发现以及没有发现进来的AIS。 Controlled slips 不包括在这个参数里面

  

  Severly Err secs

  

  对ESF 信号, 它是指下面之一的错误被探测到的时间:

  

  320 或者更多的 Path Code Violation 错误

  

  发现一个或者多个帧丢失。

  

  一个AIS 发现。

  

  对 E1-CRC 信号, 它是指下面之一的错误被探测到的时间:

  

  832 或者更多的Path Code Violation 错误

  

  发现一个或者更多的帧丢失。

  

  对 E1-nonCRC 信号, 这是2048 个Line Code Violations 或者更多存在的时间

  

  对 D4 信号, 是 发现分帧错误(Framing Errors), 或者帧丢失, 或者1544 Line Code Violations 的时间

  

  Unavail Secs

  

  接口不用的总时间,单位为秒。

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号