运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

【微思网络】配置DHCP和NAT,实现用户动态获取IP地址并访问Internet案例

运维开发网 https://www.qedev.com 2020-09-12 10:18 出处:51CTO 作者:厦门微思网络
网络拓扑图:规格适用于所有版本、所有形态的AR路由器。组网需求Router作为某企业出口网关。该企业包括两个部门A和B,分别为部门A和B内终端规划两个地址网段:10.10.1.0/25和10.10.1.128/25,网关地址分别为10.10.1.1/25和10.10.1.129/25。部门A内PC为办公终端,地址租用期限为30天,域名为huawei.com,DNS服务器地址为10.10.1.2。部

网络拓扑图:

【微思网络】配置DHCP和NAT,实现用户动态获取IP地址并访问Internet案例

规格

适用于所有版本、所有形态的 AR 路由器。

组网需求

Router 作为某企业出口网关。该企业包括两个部门 A 和 B,分别为部门 A 和 B 内终端规划两个地址网段:10.10.1.0/25 和 10.10.1.128/25,网关地址分别为 10.10.1.1/25 和

10.10.1.129/25。部门 A 内 PC 为办公终端,地址租用期限为 30 天,域名为 huawei.com,DNS服务器地址为 10.10.1.2。部门 B 内大部分是出差人员所用便携机,地址租用期限为 2 天,域名为 huawei.com,DNS 服务器地址为 10.10.1.2。企业内地址规划为私网地址,且需要访问 Internet 公网,因此,需要通过配置 NAT 实现私网地址到公网地址的转换。连接 Router 出接口 GE0/0/3 的对端 IP 地址为 2.1.1.1/24。

操作步骤

  1. Router 上的配置

#

sysname Router //修改设备名称

#

dhcp enable //使能 DHCP 功能

#

acl number 2000 //配置允许进行 NAT 转换的内网地址段 10.10.1.0/24

rule 5 permit source 10.10.1.0 0.0.0.255

#

ip pool ip-pool1

gateway-list 10.10.1.1 //配置网关地址

network 10.10.1.0 mask 255.255.255.128 //配置全局地址池可动态分配的 IP 地址范围

excluded-ip-address 10.10.1.2 //配置地址池中 10.10.1.2 不参与自动分配 dns-list 10.10.1.2 //配置 DHCP 客户端使用的 DNS 服务器的 IP 地址 lease day 30 hour 0 minute 0 //配置 IP 地址租期为 30 天 domain-name huawei.com //配置域名为 huawei.com

#

ip pool ip-pool2

gateway-list 10.10.1.129 //配置网关地址

network 10.10.1.128 mask 255.255.255.128 //配置全局地址池可动态分配的 IP 地

址范围

dns-list 10.10.1.2 //配置 DHCP 客户端使用的 DNS 服务器的 IP 地址 lease day 2 hour 0 minute 0 //配置 IP 地址租期为 2 天 domain-name huawei.com //配置域名为 huawei.com

#

interface GigabitEthernet0/0/1

ip address 10.10.1.1 255.255.255.128

dhcp select global //接口工作在全局地址池模式

#

interface GigabitEthernet0/0/2

ip address 10.10.1.129 255.255.255.128

dhcp select global //接口工作在全局地址池模式

#

interface GigabitEthernet0/0/3

ip address 2.1.1.2 255.255.255.0

nat outbound 2000 //在出接口 GE0/0/3 上做 Easy IP 方式的 NAT,实现私网地址到公网地址的转换

#

ip route-static 0.0.0.0 0.0.0.0 2.1.1.1 //配置默认路由,保证出接口到对端路由可达

#

return

  1. 验证配置结果

在 Router 上执行命令 display ip pool,可以查看 IP 地址池的分配情况。执行命令 display nat outbound,可以查看 GE0/0/3 上 NAT 的配置信息。配置成功后,终端可以动态获取 IP 地址,并能访问 Internet。

配置注意事项

配置 ACL,确定对哪些网段进行 NAT 转换。

微信咨询 微信公众号

【微思网络】配置DHCP和NAT,实现用户动态获取IP地址并访问Internet案例

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消