运维开发网

【微思网络】思科CCNA/CCNP/CCIE 配置静态MAC实例

运维开发网 https://www.qedev.com 2020-08-20 10:19 出处:51CTO 作者:厦门微思网络
MAC地址,直译为媒体存取控制位址,也称为局域网地址(LAN Address),MAC位址,以太网地址(Ethernet Address)或物理地址(Physical Address),它是一个用来确认网络设备位置的位址。在OSI模型中,第三层网络层负责IP地址,第二层数据链路层则负责MAC位址 [1] 。MAC地址用于在网络中唯一标示一个网卡,一台设备若有一或多个网卡,则每个网卡都需要并会有一个唯一的MAC地址。

配置静态 MAC 示例

拓扑图:

【微思网络】思科CCNA/CCNP/CCIE 配置静态MAC实例

静态 MAC 地址简介

MAC 地址表项是交换机通过报文的源 MAC 地址学习过程而自动生成的,而通过用户手动配置也可以生成静态的 MAC 地址表项。

手动配置静态 MAC,一般是为了防止假冒身份的非法用户骗取数据,由网络管理员手动在 MAC 地址表中添加合法用户的 MAC 地址表项。

手动配置静态 MAC 地址表项的数量比较大时,不便于网络管理员维护,此时可以使用端口安全功能实现 MAC 地址和接口的动态绑定。

配置注意事项

本举例适用于 S 系列交换机所有产品的所有版本。

组网需求

如图 1 所示,服务器通过 GE1/0/2 接口连接交换机。为避免交换机在转发目的地址为服务

器地址的报文时进行广播,要求在交换机上设置服务器的静态 MAC 地址表项,使交换机始终

通过 GE1/0/2 接口单播发送去往服务器的报文。为了保证 PC 用户和服务器的安全通信,同时

把 PC 用户的 MAC 地址和接口 GE1/0/1 静态绑定。

配置思路

采用如下思路配置静态 MAC:

  1. 在交换机上创建 VLAN,并将接口加入 VLAN,实现二层转发功能。

  2. 在交换机上配置服务器的静态 MAC 地址表项。

  3. 在交换机上配置 PC 的静态 MAC 地址表项。

操作步骤

  1. 在 Switch 上创建 VLAN 2,并把接口 GE1/0/1 和 GE1/0/2 加入 VLAN 2

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 2 //创建 VLAN 2

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type access //和接入设备 PC 相连的

接口类型必须是 access,接口默认类型不是 access,需要手动配置为 access

[Switch-GigabitEthernet1/0/1] port default vlan 2 //接口 GE1/0/1 加入 VLAN 2

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2 //接口 GE1/0/2 的配置方法和接口

GE1/0/1 相同

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port default vlan 2 [Switch-GigabitEthernet1/0/2] quit

2.在 Switch 上添加服务器对应的静态 MAC 地址表项

[Switch] mac-address static 4-4-4 gigabitethernet 1/0/2 vlan 2

3.在 Switch 上添加 PC 对应的静态 MAC 地址表项

[Switch] mac-address static 2-2-2 gigabitethernet 1/0/1 vlan 2

4.检查配置结果

在任意视图下执行 display mac-address static vlan 2 命令,查看静态 MAC 表是否添加成功。

[Switch] display mac-address static vlan 2 -------------------------------------------------------------------------- -----

MAC Address VLAN/VSI Learned-From Type


0002-0002-0002 2/- GE1/0/1

static

0004-0004-0004 2/- GE1/0/2

static


Total items displayed = 2

配置文件

Switch 的配置文件

#

sysname Switch

#

vlan batch 2

#

interface GigabitEthernet1/0/1

port link-type access

port default vlan 2

#

interface GigabitEthernet1/0/2

port link-type access

port default vlan 2

#

mac-address static 0002-0002-0002 GigabitEthernet1/0/1 vlan 2

mac-address static 0004-0004-0004 GigabitEthernet1/0/2 vlan 2

#

return

微信咨询 微信公众号

【微思网络】思科CCNA/CCNP/CCIE 配置静态MAC实例

0

精彩评论

暂无评论...
验证码 换一张
取 消