运维开发网

EIGRP和OSPF__EIGRP

运维开发网 https://www.qedev.com 2020-06-21 09:52 出处:网络 作者:运维开发网整理
EIGRP解释 1.Enhanced Interior Gateway Routing Protocol 即增强内部网关路由协议。EIGRP同内部网关路由选择协议(IGRP)一样,是Cisco公司的私有协议。   Cisco公司是该协议的发明者和唯一具备该协议解释和修改权的厂商。 EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采   用弥散修正算法(DUAL)来实现快速收敛

EIGRP解释

1.Enhanced Interior Gateway Routing Protocol 即增强内部网关路由协议。EIGRP同内部网关路由选择协议(IGRP)一样,是Cisco公司的私有协议。

  Cisco公司是该协议的发明者和唯一具备该协议解释和修改权的厂商。 EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采

  用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用,支持Appletalk、IP和NetWare等多种网络层协议。

2.增强IGRP(EIGRP)是一个无类、增强的距离矢量协议。如同IGRP,EIGRP也使用了自治系统的概念来描述相邻路由器的集合,集合中的路由器使用相同的

  路由选择协议并共享相同的路由选择信息。但与IGRP不同的是,EIGRP在它的路由更新中包含了子网掩码。子网掩码信息的通告使得在设计网络时可以

  使用可变长子网掩码(VLSM)及汇总!

  有时EIGRP也被称为是混合型路由选择协议,因为它同时拥有距离矢量和链路状态两种协议的特性。例如,EIGRP不会像OSPF那样发送链路状态数据包,

  相反,它发送传统的距离矢量更新,在此更新中会包含有网络信息及从发出通告的路由器达到这些网络的开销。并且EIGPR也拥有链路状态的特性,

  即它也在启动时同步相邻路由器间的路由表,并在随后发送特定的更新数据,而且也是只在拓扑结构发生改变时发送。这使得EIGRP非常适于在特大网络中

  应用。EIGRP的最大跳计数为255(其默认设置为100)。

  Cisco称EIGRP为距离矢量路由选择协议,有时也称之为增强距离矢量路由选择协议,甚至称之为混合路由选择协议。

3.EIGRP是Cisco的私有路由协议,它综合了距离矢量和链路状态两者的优点,它的特点包括:

  1)快速收敛

  EIGRP采用DUAL来实现快速收敛。运行EIGRP的路由器存储了邻居的路由表,因此能够快速适应网络中的变化。如果本地路由表中没有合适的路由且

  拓扑表中没用合适的备用路由,EIGRP将查询邻居以发现替代路由。查询将不断传播,直到找到替代路由或确定不存在替代路由

  2)部分更新

  EIGRP发送部分更新而不是定期更新,且仅在路由路径或者度量值发生变化时才发送。更新中只包含已变化的链路的信息,而不是整个路由表,

  可以减少带宽的占用。此外,还自动限制这些部分更新的传播,只将其传递给需要的路由表,因此EIGRP消耗的带宽比IGRP少很多。

  这种行为也不同于链路状态路由协议,后者将更新发送给区域内的所有路由器。

  3)使用多播和单播

  EIGRP在路由器之间通信时使用多播和单播而不是广播,因此终端站不受路由更新和查询的影响。EIGRP使用的多播地址是224.0.0.10。

  4)支持变长子网掩码(VLSM)

  EIGRP是一种无类路由协议,它将通告每个目标网络的子网掩码,支持不连续子网和VLSM/CIDR。

  5)无缝连接数据链路层协议和拓扑结构

  EIGRP不要求对OSI参考模型的2层协议做特别的配置.不像OSPF,OSPF对不同的2层协议要做不同配置,比如以太网和帧中继,EIGRP能够有效的工作在

  LAN和WAN中,而且EIGRP保证网络及不会产生环路(loop-free);而且配置起来很简单;支持VLSM;它使用组播和单播,不使用广播,

  这样做节约了带宽;它使用和IGRP一样的度量值算法,但是EIGRP度量值是32位的;它可以做非等价的路径的负载平衡.

  6)通过协议相关模块支持IP和IPv6(及其他一些较少使用的被动路由协议)

  7)基于可靠传输协议(RTP)的通信

4.可靠传输协议:

  EIGRP使用专用的协议(称为可靠传输协议RTP)来管理EIGRP路由器间的消息通信。Cisco设计了一种使用杠杆机制来调节组播与单播的工作机理,

  实现了数据更新的快速传递,及对接收数据的跟踪。当EIGRP发送组播数据时,它使用D类地址的224.0.0.10。每台EIGRP路由器都会意识到它的邻居是

  谁,它的组播将发送给谁,它维护着一个回复应答的邻居列表。如果EIGRP没有从某个邻居那里得到应答,它将使用单播来重发同样的数据。

  如果在16次单播尝试后,它仍然没有得到应答,则此邻居将被宣告消失。这个过程称为可靠组播。

  通过为每个数据包指定一个序列号,路由器可以保持对所发送信息的跟踪。使用这种技术,路由器可以从接收数据中鉴别出过时的、重复的或者是错序的

  信息。EIGRP依靠它在启动时同步路由数据库的能力,并且只传送任何改变的部分,很好地维持了启动后数据库的连贯性。否则,持续的丢包或接收错序,

  将会导致路由数据库的混乱。

5.弥散更新算法

  EIGRP为选择并维持到达每个远程网络的最佳路径使用弥散更新算法(DUAL)。这个算法可以做到:

  ? 如果可用,就路由备份

  ? 支持变长子网掩码(VLSM)

  ? 动态的路由恢复

  ? 如果没有路由被发现,则查询替换路由

  DUAL为EIGRP提供了在所有协议中尽可能快的路由收敛时间。EIGRP快速收敛的关键有两点:首先,EIGRP路由器维持其所有邻居的路由拷贝,

  使用这个拷贝可以计算出它们自己到达远程网络的开销。如果最佳路径不存在了,它只需简单测试此拓扑表中的内容,并从中选择出最佳的替代路由;

  第二,在它本地拓扑表中没有可替代的路由时,EIGRP路由器会很快地询问它们的邻居来帮它找出一个。对其他路由器的依赖和对它们提供信息的平衡

  就是DUAL的弥散特性。

  Hello协议的中心思想就是实现对新的或已消失的邻居进行快速判断。RTP满足了提供可靠传输及顺序控制机制的需求。DUAL则负责选择并管理最佳的

  路径信息,为整个协议的实现建立了牢固的基础。

6.多个AS

  EIGRP使用自治系统号来区别可共享路由信息的路由器集合。路由信息只可以在拥有相同自治系统号的路由器间共享。在大型网络中,

  你可以轻易地在那些分散的计算操作中,终结因复杂的拓扑和路由表而导致的慢收敛。

  那么,什么可以用来缓解管理员管理真正的大型网络而产生的压力呢?显然,可行的办法就是将这个网络分割为多个独立的EIGRP自治系统,或AS。

  每个AS由一系列相邻的路由器所组成,路由信息可以通过再发布在不同的AS中间进行共享。

  在EIGRP内部使用的再发布会让我们了解到另外一个有趣的内容。内部EIGRP的路由的管理距离(AD)是90。这些路由发源于指定自治系统中那些属于

  同一个自治系统的EIGRP路由器。而另一种类型的路由称为外部EIGRP路由的AD是170,它的级别比较低。这些路由也会出现在EIGRP路由表内,

  不论它是手工输入的还是自动再发布的,它们代表发源于EIGRP自治系统外部的网络。不论这些路由来源于另一个 EIGRP自治系统,

  还是另一种路由选择协议,在EIGRP内部再发布时,它们都被称为外部路由。

  一旦为 EIGRP配置了与使用IGRP时相同的自治系统号,EIGRP会自动在EIGRP中再发布来自IGRP的路由。当然,EIGRP会将这些路由视为外部路由(AD为

  170),因此你永远不用为这些事情担心。你只需要尽可能快地完成这个迁移,并且也正由于有这一自动再发布功能,你不需要再牺牲周末来完成迁移。

7.VLSM支持和路由汇总

  作为一无类路由选择协议,EIGRP支持使用变长子网掩码。EIGRP通过使用子网掩码允许保留一定的地址空间,以满足对主机的各种需要,

  如使用30位的子网掩码为点到点网络进行配置。并且,由于子网掩码是随每个路由更新一同传播的,EIGRP甚至支持不连续的子网应用,

  这一应用可以为我们在设计网络的IP寻址计划时提供更大的灵活性。

  不连续的网络:是将两个或更多有类网络的子网通过不同的有类网络连接在一起的网络。

   

EIGRP和OSPF__EIGRP

  子网172.16.10.0和172.16.20.0通过10.3.1.0网络连接在了一起。默认时每台路由器都被只认为是172.16.0.0有类网络。

  了解不连续网络不能与RIPv1或IGRP一起工作是很重要的。默认时在RIPv2或EIGRP中,网络也是不工作的,但是默认时在OSPF网络上的不连续网络

  却是可以工作的,这是因为OSPF不像EIGRP一样能自动汇总。

  EIGRP也支持在任一或全部EIGRP路由器上创建路由汇总,路由汇总可以尽可能缩减路由表的尺寸。然而,EIGRP可以在它们有类网络的边界上自动进行

  汇总,下图显示了运行EIGRP的路由器是如何看待这一网络和自动汇总边界的

   

EIGRP和OSPF__EIGRP

  显然,默认时这个网络是决不会工作的!注意,默认时,RIPv1、RIPv2和IGRP也可以在这些相同的有类边界上执行自动汇总,但OSPF则不能。

  注:RIPv2和EIGRP支持不连续的网络划分,但不是在默认状态下。OSPF默认时支持不连续的网划分,因为它不像RIP和EIGRP一样自动汇总有类边界。

8.路由发现和维护

  正如许多链路状态协议一样,EIGRP支持邻居的概念,这些邻居是通过Hello过程来发现的,并且邻居状态是要受监视的。像许多距离矢量协议一样,

  EIGRP使用在前面介绍过的传言路由机制,即大部分路由器是决不会了解到第一手路由更新的。在这里有所不同的是,这些路由器可以从一些路由器

  那里了解到更新的信息,也可以从其他的另外一些路由器那里了解到它们。

  EIGRP路由器必须收集大量的信息,这会导致一个问题,它们必须有空间来保存这些信息。EIGRP使用了一系列的表来保存这些关于环境的重要信息。

  邻居关系表:记录着有关路由器与已建立起来的邻居关系的信息。

  拓扑表:保存着在互联网络中每个路由器从每个邻居处接收到的路由通告。

  路由表:保存着当前使用着的用于路由判断的路由。对于由EIGRP支持的每个协议所产生的每个表,在这里都有一个独立的备份。

  EIGRP路由器的RAM里存有三个表:邻居关系表,拓扑表和路由表. 邻居关系表,拓扑表通过Hello数据包建立和管理。

  EIGRP successor routes stored in the topology table and the neighbor table(EIGRP继任者路由器保存于拓扑表和邻居关系表)

9.EIGRP的度量

  与许多其他只使用单一量度来比较并选择最佳可用路径的协议不同,EIGRP使用由4个要素组成的度量。这些要素是:

  ? 带宽? 延迟? 负载? 可靠性

  同IGRP一样,默认时,EIGRP只使用带宽和线路的延迟来判定到达远程网络的最佳路径。有时Cisco喜欢称它们为路径带宽值和线路延迟累积值。

  另外,值得注意的是,还有第五个元素,最大传输单元(MTU)尺寸。这个元素在EIGRP的计算中决没有被用到,但是在一些与EIGRP相关的命令中,

  它是一个必需的参数,特别是那些涉及再发布的命令。MTU元素的值表示去往目的网络过程中所遇到的最小MTU值。

10. 最大路径数和跳计数

  默认时,EIGRP(和IGRP)可以支持最多到4条链路的不等代价的负载均衡(实际上,所有的路由选择协议都可以做到这点)。然而,通过使用下列命令,

  可以使EIGRP实际用于实现负载均衡的链路(平衡或不平衡的)数量达到6:

  Pod1R1(config)#router eigrp 10

  Pod1R1(config-router)#maximum-paths ?

  <1-6> Number of paths

  另外,EIGRP的最大跳计数值为100,但它可以被设置到255。通常不需要修改这个值,如果需要,可以这样做:

  Pod1R1(config)#router eigrp 10

  Pod1R1(config-router)#metric maximum-hops ?

  <1-255> Hop count

  正如在上面的输出中所看到的,EIGRP可以设置的最大跳数为255,注意,即使在路径度量的计算中不使用跳计数,路由器仍会使用这个最大跳计数来

  限制 AS的范围。

  说明:默认时所有的路由选择协议都能通过4条相同代价的链路实现负载均衡。然而,EIGRP允许你通过6条链路实现负载均衡,并且通过使用variance

  命令,EIGRP可以在6条不等代价的链路上实现负载均衡。

11. 环路解决

  EIGRP对于环路的防止考虑两方面:

  1.水平分割(Split Horizon)

  永远不会在同一个接口下通告一条该接口学到的路由信息

  2.路由的毒性逆转(Poison reverse)

  接收路由信息的接口,再从该接口通告出刚才学到的路由为不可达

  触发条件:

  当两台路由器进行邻居初始化时,他们会互相以最大的metric值通告回刚才学到的路由信息(路由中毒)

  当拓扑发生改变时,会临时关闭水平分割和毒性逆转,重新学习拓扑

  发送查询请求时,会引起水平分割,比如当一个路由器查询一条未知网段去向时,他会向每一个邻居发送查询,处于该网段的继承者(successor)

  会返回查询给该路由器,而该路由器会反馈一个查询结果给其他邻居,不会再次告诉那个继承者要走这个网段应该要经过自己

12. 其他区别

  EIGRP是cisco专用的,而OSPF则是通用的协议。

  EIGRP是一个距离矢量协议(有些资料说是混合型的),而OSPF是链路状态协议。

  EIGRP默认开启自动汇总功能,它可以在A.B.C类网络的边界实现自动汇总,同时也支持手动配置;而OSPF汇总则必须手动配置

  EIGRP的汇聚速度要比OSPF快,因为在它的拓扑图中保存了可选后继,直接后继找不到时可以直接通过可选后继转发。

  EIGRP的多播地址是224.0.0.10,OSPF是224.0.0.5和224.0.0.6。

  EIGRP的路径度量是复合型的,OSPF则是Cost型的(当然一般的cost还是根据bandwidth来计算的)

  尽管EIGRP支持路由汇总功能,但是它没有分级(hierachical)路由的概念,不像OSPF那样对网络进行分级。

  在邻居关系的建立上,EIGRP没有OSPF那么复杂的down-init-two way的过程,只要一个路由器看到邻居的hello包,它就与之建立邻接关系。

  在汇总功能的实现上,EIGRP可以在任何路由器的任何接口实现,而OSPF则只能在ABR和ASBR上实现,而且它的路由汇总不是基于接口的。

  EIGRP支持不等路径度量值的负载均衡,而OSPF则只支持相等度量值的负载均衡。

  EIGRP邻接关系的确立只要两个参数相符合就行:K-value和AS number;而OSPF的邻接关系的建立需要多个参数符合:hello/dead timer,authentication   password,area id,stub flag等。

  最后就是它们配置以及检查(show command)上的不同了,这方面不同点很多,就要慢慢体会了。如ospf 中的show ip ospf database对应eigrp中的show   ip eigrp topology。

13. EIGRP与IGRP在network命令的区别在于多了wildcard-mask参数,即通配符掩码。如果网络定义使用的是默认掩码,则wildcard-mask参数可以省略:

  如果网络定义使用的不是默认掩码,则wildcard-mask参数必须标明。

  EIGRP在处理有类别(A、B、C类)网络地址时,会自动地汇总路由。这意味着即使规定RTC连接的是10.0.3.0/24这个网络,但EIGRP仍然会发布其连接

  整个A类网络10.0.0.0。在EIGRP中,路由自动汇总功能默认是有效的。存在不连续子网的网络中,通常需要用no auto-summary命令来关闭该功能。

14. a) 如果使用了network 命令,并且没有添加反掩码,那么network 后的网络参数必须为有类主网,该台路由器上所有满足所指定的主类网络范围的接口将会

  被加入EIGRP 进程。

  b)如果使用了network 命令,并且添加了反掩码,那么network 后的网络参数和反掩码准确匹配的网络范围将和路由器上直连接口相互比较,满足该范围的

  被加入EIGRP 进程。

15. 排错命令

  show run | begin router eigrp//查看配置文件中eigrp的配置命令

  show ip protocols//列举在每个路由进程下的network命令的内容和邻居IP地址

  show ip route summary//查看eigrp路由汇总状态

  show ip eigrp neighbors//列举出已知的EIGRP 邻居,但不会列举出因参数不匹配而不可用的邻居。

  show ip eigrp interface//查看各个运行eigrp的接口状态

  show ip eigrp interface detail//查看各个运行eigrp的接口详细状态

  show ip route eigrp//查看eigrp协议学习到的路由表

  show ip eigrp topology//查看本台路由器上后继路由和可行性后继路由的情况。但不会显示所有已知的路由。

  show ip eigrp topology all-links//查看eigrp完整的拓扑表

  show ip eigrp topology 10.1.1.0 255.255.255.0//查看指定的某个网络参数信息

  debug eigrp packets//调试eigrp的查讯包

  debug eigrp fsm //调试eigrp的dual算法调试信息

   Corp#sh ip eigrp neighbors

  IP-EIGRP neighbors for process 10

  H  Address  Interface  Hold  Uptime  SRTT  RTO  Q  Seq

  (sec) (ms) Cnt Num

  1  10.1.3.2  Se0/0/1  14  00:35:10  1  200  0  81

  H字段指示了邻居被发现的顺序。

  Hold时间是这台路由器从指定邻居那里接收Hello数据包还要等待多长时间。

  ? Uptime指示这个邻居关系已经建立了多久。

  ? SRTT字段是一个连续的往返定时器,用于指示从此路由器到它邻居并返回的往返时间。这个值常用来确定在一个组播发出之后,为来自邻居的应答

  需要等待多长时间。如果某个应答没有在指定的时间内接收到,那么这台路由器将会切换到使用单播来尝试完成这次通信。用于指定组播尝试时间。

  ? 重传超时(RTO)字段,这是EIGRP从到邻居的重传队列进行重传某个数据包之前需要等待的时间数值。

  ? Q值指示在队列中是否存在异常消息,通常较大的取值都将指示某个问题。

  ? Seq字段指示来自邻居的最近更新的序列号,用于管理同步及避免信息处理中的重复或者错序。

16. 将R的E0/0接口设置为被动接口。

  R(config)#router eigrp 100

  R(config-router)#passive-interface e0/0 //将E0/0设置为被动接口,即接受到但阻塞

  完成这个配置将会阻止此接口发送或接收Hello数据包,这样做的结果是,将会中止它已建立起来的邻居关系。这就意味着在这个接口上不能再发送或

  接收路由信息了。

  说明:passive-interface命令的影响取决于命令发布时所涉及的路由选择协议。例如,在某个接口上运行的是RIP,此passive-interface命令将阻止路由更新

  的发送。但却允许对路由更新的接收。因而,带有被动接口的RIP路由器将仍然可以从其他路由器的通告中认识网络。这与EIGRP是不同的,在

  EIGRP中,一个被动接口既不发送更新也不接收更新。

17. 通过路由器上实时出现的日志可以判断EIGRP 邻居建立完成。

  *Mar 1 00:05:41.791: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.10.12.2(Ethernet0/0) is up: new adjacency

18. EIGRP拥有较低的AD。可是,由于有RIP在后台运行。不仅要消耗路由器更多的内存和CPU处理时间,而且还要从所有的链路中抽取出宝贵的带宽资源!

  我们需要修改RIP跳计数的度量来匹配EIGRP的带宽、延迟、可靠性、负载以及MTU的度量。当配置再发布时,即使EIGRP使用的是默认值,即只考虑线路

  的带宽和延迟,你也必须配置所有的度量值。

  现在,我们的R3路由器可以同时使用RIP和EIGRP这两种协议。它甚至可以作为我们所使用的其他多数路由器的翻译。由于这台871W路由器只能接收

  RIP,因此,我们仍然需要配置从EIGRP到RIP的再发布(相互的再发布),这样871W就可以将EIGRP路由作为RIP路由进行接收,我们现在来完成这一操 

  作:

  R3(config)#router rip

  R3(config-router)#redistribute eigrp 10 ?

  metric Metric for redistributed routes

  route-map Route map reference

  <cr>

  R3(config-router)#redistribute eigrp 10 metric ?

  <0-16> Default metric

    transparent Transparently redistribute metric

  R3(config-router)#redistribute eigrp 10 metric 1

  上面的输出表明,我们正在进行EIGRP到RIP的重分发,并且也修改了跳计数的度量。

  这里只有一种方式可以证明这样的配置是正确的并且也是可行的,那就是在除路由器R3之外的所有路由器上禁用RIP,而R3要为路由器871W提供转换。

使用EIGRP进行负载均衡

  EIGRP允许不平衡开销的负载均衡、可控制的路由选择更新和正式的邻居关系。

1.查看一下R1的路由表,并确认EIGRP已经发现路由器间的两条链路:

  R1#sh ip route

  10.0.0.0/24 is subnetted, 12 subnets

  D 10.1.11.0 [90/2684416] via 10.1.3.1, 00:50:37, Serial0/0/1

  [90/2684416] via 10.1.2.1, 00:50:37, Serial0/0/0

  D 10.1.10.0 [90/2707456] via 10.1.3.1, 01:04:40, Serial0/0/1

  [90/2707456] via 10.1.2.1, 01:04:40, Serial0/0/0

  D 10.1.9.0 [90/2707456] via 10.1.3.1, 01:24:09, Serial0/0/1

  [90/2707456] via 10.1.2.1, 01:24:09, Serial0/0/0

  D 10.1.8.0 [90/2707456] via 10.1.3.1, 01:24:09, Serial0/0/1

  90/2707456] via 10.1.2.1, 01:24:09, Serial0/0/0

  D 10.1.12.0 [90/2684416] via 10.1.3.1, 00:10:10, Serial0/0/1

  [90/2684416] via 10.1.2.1, 00:10:10, Serial0/0/0

  C 10.1.3.0 is directly connected, Serial0/0/1

  C 10.1.2.0 is directly connected, Serial0/0/0

  D 10.1.1.0 [90/2172416] via 10.1.3.1, 01:24:11, Serial0/0/1

  [90/2172416] via 10.1.2.1, 01:24:11, Serial0/0/0

  C 10.1.7.0 is directly connected, FastEthernet0/1

  C 10.1.6.0 is directly connected, FastEthernet0/0

  D 10.1.5.0 [90/2681856] via 10.1.3.1, 01:24:11, Serial0/0/1

  [90/2681856] via 10.1.2.1, 01:24:11, Serial0/0/0

  D 10.1.4.0 [90/2681856] via 10.1.3.1, 01:24:11, Serial0/0/1

  [90/2681856] via 10.1.2.1, 01:24:11, Serial0/0/0

  路由表中每个路由都有两条链路,并且在默认时,EIGRP将在S0/0/0和S0/0/1上实现负载均衡,因为它们具有相同的度量。

  EIGRP确实提供了一些非常好的功能,其中之一就是自动负载均衡。但是对于成束的链路又会怎样?EIGRP也允许我们去实现负载均衡,甚至不需要额外的

  配置!使用相同的子网来配置路由器Corp和R1之间的链路,即两条链路的所有接口都将在同一个子网中。

  Corp#config t

  Corp(config)#int s0/0/1

  Corp(config-if)#ip address 10.1.2.4 255.255.255.0

  R1#config t

  R1(config)#int s0/0/1

  R1(config-if)#ip address 10.1.2.3 255.255.255.0

  R1(config-if)#do show run | begin interface

  interface Serial0/0/0

  description 1st Connection to Corp Router

  ip address 10.1.2.2 255.255.255.0

  !

  interface Serial0/0/1

  description 2nd connection to Corp Router

  ip address 10.1.2.3 255.255.255.0

  现在,两条链路的4个接口都在同一个子网中。

  R1(config-if)#do show ip route

  10.0.0.0/24 is subnetted, 12 subnets

  D 10.1.11.0 [90/2684416] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/2684416] via 10.1.2.1, 00:04:44, Serial0/0/0

  D 10.1.10.0 [90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/2707456] via 10.1.2.1, 00:04:44, Serial0/0/0

  D 10.1.9.0 [90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/2707456] via 10.1.2.1, 00:04:44, Serial0/0/0

  D 10.1.8.0 [90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/2707456] via 10.1.2.1, 00:04:44, Serial0/0/0

  D 10.1.12.0 [90/2684416] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/2684416] via 10.1.2.1, 00:04:44, Serial0/0/0

  D 10.1.3.0 [90/3193856] via 10.1.2.4, 00:04:44, Serial0/0/1

  [90/3193856] via 10.1.2.1, 00:04:44, Serial0/0/0

  C 10.1.2.0 is directly connected, Serial0/0/0

  is directly connected, Serial0/0/1

  D 10.1.1.0 [90/2172416] via 10.1.2.4, 00:03:56, Serial0/0/1

  [90/2172416] via 10.1.2.1, 00:03:56, Serial0/0/0

  C 10.1.7.0 is directly connected, FastEthernet0/1

  C 10.1.6.0 is directly connected, FastEthernet0/0D 10.1.5.0 [90/2681856] via 10.1.2.4, 00:04:46, Serial0/0/1

  [90/2681856] via 10.1.2.1, 00:04:46, Serial0/0/0

  D 10.1.4.0 [90/2681856] via 10.1.2.4, 00:04:46, Serial0/0/1

  [90/2681856] via 10.1.2.1, 00:04:46, Serial0/0/0

  提示:首先必须确保EIGRP是开启的。如果不这样,你将会在路由器上收到一个地址重叠的错误提示!

  你是否注意到在当前的路由表中出现了一个或两个细微的变化?通常,网络 10.1.2.0和10.1.3.0都显示为单独的、直接连接的接口,但这里不再是了。

  现在只有10.1.2.0网络显示为两个直接连接的接口,并且这台路由器现在有一个3MB的管道通过这个线路,而不再只是两个1.5Mb/s的T1链路。

  正是由于这些变化是细微的,才没有使它们太显眼!

  等一下,为什么10.1.3.0仍然会出现在路由表中,并且为什么它会显示为D,也就是为EIGRP使用的DUAL,即使子网10.1.3.0不存在?答案相当简单,当

  我们在R3路由器上通过SDM配置静态路由时,我单击了“Permanent”路由选项。这个命令的作用是,“如果任一静态网络关闭,在路由器R3的路由表中都将

  仍然保持这个路由”。路由器Corp和R1之间并没有被配置网络10.1.3.0,但由于我们在路由器 R3上配置了再发布命令,因此即使网络10.1.3.0确实已经不存

  在了,路由器 R3会依然通告10.1.3.0为可用的。

  警告:这就是为什么不随静态路由使用Permanent选项的真实原因,因为如果你这样用了,你的路由表就会显示一个根本不存在的子网!

  我将会把子网10.1.3.0添加回这个网络中,这样,使用这些双链路就会更有趣。我将在Corp和R1的S0/0/1接口上配置10.1.3.1/24和10.1.3.2/24。

  现在10.1.3.0又开始被通告了,但这一次它是被作为实际存在的网络通告的。我们把事情搞得更复杂一些,将10.1.3.0链路的度量做一点修改,

  再看一下会发生些什么:

  R1(config)#int s0/0/1

  R1(config-if)#bandwidth 256000

  R1(config-if)#delay 300000

  Corp(config)#int s0/0/1

  Corp(config-if)#bandwidth 256000

  Corp(config-if)#delay 300000

  由于默认时,EIGRP使用线路的带宽和延迟来判断到达每个网络的最佳路径,因此我降低了路由器R1和Corp间S0/0/1接口上的带宽并增加了它的延迟。

  现在,我们再来检验一下网络中的EIGRP,并查看一下在路由器R1和Corp之间的两链路现在变成了什么。

 配置1 

  

EIGRP和OSPF__EIGRP

1.条件:如图,PC2、3地址分别为100.100.100.3和100.100.100.4。要求:PC0、1通过R0下发192.168.1.0网段地址并能连接到PC2、3;

  路由器间通过Eigrp协议通信;。

2.步骤

  1)路由器R0设置dhcp服务、eigrp宣告192.168.1.0、219.224.97.0、默认路由。

   

EIGRP和OSPF__EIGRP

  2)R1设置默认路由、NAT、访问控制列表、Eigrp宣告219.224.97.0(不用宣告99.99.99.0)注:需加上反子网掩码

  

EIGRP和OSPF__EIGRP

  注:访问控制列表名称必须与NAT配置列表一致。

   

EIGRP和OSPF__EIGRP

  3)R2 配置相应端口IP地址。

   

EIGRP和OSPF__EIGRP

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号