运维开发网

HUAWEI HCIA R&S RIP实验

运维开发网 https://www.qedev.com 2020-06-18 10:20 出处:51CTO 作者:wx5ee64cc306f52
RIP简介

动态路由协议RIP

RIP=UDP+520端口

学习RIP首先的了解什么是距离矢量算法

什么是距离矢量算法

是一个比较简单的算法 距离矢量是依据传闻进行传递的

R1---R2---R3

如果R1 2 3 都运行RIP协议的话

R1有一个100网段 此时R3想要学习到这个100网段 R1会把100网段让R2学习到,R2最终把100网段给了R4

结论就是:R3想要学习到100网段 就是R2告诉给R4得

RIP版本:

Version 1 广播传递消息

Version 2 推荐大家用version 2版本 用组播传递消息 224.0.0.9

Version 1 2 华为默认这个版本

RIP开销

是以跳数作为一个衡量值 跳数越少 选路优先选择

什么是跳数 每经过一台路由器(或者三层交换机)跳数就会+1 如果这个数据包经过路由器得数量大于等于16话 第16台路由器直接会把这个数据包丢弃 (即第十六跳不可达)所以 RIP协议 不适用于大型网络

缺点:这个计算的开销的方式很容易绕过高速链路而走低速链路

RIP防环机制

水平分割---华为默认开启

路由器从一个接口G0/0/0收到得路由 只会向邻居进行发送 不会从G0/0/0接口发回去

毒性反转---华为默认不开启

从一个接口收到的路由 会从该接口发出去 并且发送的时候 rip的跳数直接设置16跳 默认不开启

注意:如果同时开启水平分割和毒性反转的话 优先毒性反转生效

触发更新---默认开启

比较靠谱的 触发更新是指当路由信息发生变化时,立即向邻居设备发送触发更新报文 他是可以加快收敛的

topo如下,

HUAWEI HCIA R&S RIP实验

配置设备名称和IP地址。

在R1 R2 R3运行RIP,完成以下需求:

使用RIPv2所有接口启用md5密文验证

算法使用华为usual,口令为“huawei”(不含引号)全网互通

实验配置

IP地址规划

R1

interface GigabitEthernet0/0/0
 ip address 192.168.12.1 255.255.255.0 
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255 

R2

interface GigabitEthernet0/0/0
 ip address 192.168.12.2 255.255.255.0 
interface GigabitEthernet0/0/1
 ip address 192.168.23.2 255.255.255.0 
interface GigabitEthernet0/0/2
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255

R3

interface GigabitEthernet0/0/0
 ip address 192.168.23.3 255.255.255.0 
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255

RIP的配置

R1

rip 10
 undo summary //关闭自动汇总 
 version 2     // 选择v2的版本
 network 1.0.0.0   //rip稚嫩宣告主类的网段
 network 192.168.12.0

R2

rip 10
 undo summary
 version 2
 network 2.0.0.0
 network 192.168.12.0
 network 192.168.23.0

R3

rip 10
 undo summary
 version 2
 network 3.0.0.0
 network 192.168.23.0

RIP认证

R1

[R1]interface GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0]rip authentication-mode  md5  usual  cipher  huawei

R2

[R2]interface GigabitEthernet0/0/0
[R2-GigabitEthernet0/0/0]rip authentication-mode  md5  usual  cipher  huawei

检查

R1路由表

HUAWEI HCIA R&S RIP实验

R1--ping--R3

HUAWEI HCIA R&S RIP实验

0

精彩评论

暂无评论...
验证码 换一张
取 消