运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

实验 端口聚合配置

运维开发网 https://www.qedev.com 2020-02-17 10:02 出处:网络 作者:wb57ce870a60888
实验 端口聚合配置【实验名称】端口聚合配置。【实验目的】理解端口聚合的工作原理,掌握如何在交换机上配置端口聚合。【背景描述】假设某企业采用两台交换机组成一个局域网,由于很多数据流量是跨过交换机进行转发的,因此需要提高交换机之间的传输带宽,并实现链路冗余备份,为此网络管理员在两台交换机之间采用两根网线互连,并将相应的两个端口聚合为一个逻辑端口,现要在交换机上做适当配置来实现这一目标。【需求分析】需要

实验 端口聚合配置

【实验名称】

端口聚合配置。

【实验目的】

理解端口聚合的工作原理,掌握如何在交换机上配置端口聚合。

【背景描述】

假设某企业采用两台交换机组成一个局域网,由于很多数据流量是跨过交换机进行转发

的,因此需要提高交换机之间的传输带宽,并实现链路冗余备份,为此网络管理员在两台交

换机之间采用两根网线互连,并将相应的两个端口聚合为一个逻辑端口,现要在交换机上做

适当配置来实现这一目标。

【需求分析】

需要在两台交换机之间的冗余链路上实现端口聚合,并且在聚合端口上设置 Trunk,以

增加网络骨干链路的带宽。

【实验拓扑】

图 4‐ 2 实验拓扑图

按照拓扑图连接网络时注意,两台交换机都配置完端口聚合后,再将两台交换机连接

起来。如果先连线再配置可能会造成广播风暴,影响交换机的正常工作。

【实验设备】

三层交换机 1 台

二层交换机 1 台

【预备知识】

交换机的基本配置方法,VLAN 的工作原理和配置方法,Trunk 的工作原理和配置方法,

SVI 端口的配置方法,聚合端口的工作原理和配置方法

【实验原理】

端口聚合(Aggregate-port)又称链路聚合,是指两台交换机之间在物理上将多个端口

连接起来,将多条链路聚合成一条逻辑链路。从而增大链路带宽,解决交换网络中因带宽引

起的网络瓶颈问题。多条物理链路之间能够相互冗余备份,其中任意一条链路断开,不会影

响其他链路的正常转发数据。

端口聚合遵循 IEEE 802.3ad 协议的标准。

【实验步骤】

第一步:配置两台交换机的主机名和管理 IP  地址

S3750#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

S3750(config)#hostname L3-SW

L3-SW(config)#interface vlan 1

L3-SW(config-if)#Dec 3 01:03:22 L3-SW %7:%LINE PROTOCOL CHANGE:

Interface VLAN 1, changed state to UP

L3-SW(config-if)#ip address 192.168.1.1 255.255.255.0

L3-SW(config-if)#no shutdown

L3-SW(config-if)#exit

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname L2-SW

L2-SW(config)#interface vlan 1

L2-SW(config-if)#ip address 192.168.1.2 255.255.255.0

L2-SW(config-if)#no shutdown

L2-SW(config-if)#exit

第二步:在两台交换机上配置聚合端口

L3-SW(config)#interface range fastEthernet 0/1-2

L3-SW(config-if-range)#port-group 1

!将端口 Fa0/1~2 加入聚合端口 1,同时创建该聚合端口

L3-SW(config-if-range)#Dec 3 01:03:57 L3-SW %7:%LINE PROTOCOL CHANGE:

Interface AggregatePort 1, changed state to UP

Dec 3 01:03:58 L3-SW %7:%LINK CHANGED: Interface FastEthernet 0/1, changed

state to administratively down

Dec 3 01:03:58 L3-SW %7:%LINE PROTOCOL CHANGE: Interface FastEthernet

0/1, changed state to DOWN

Dec 3 01:03:58 L3-SW %7:%LINK CHANGED: Interface FastEthernet 0/2, changed

state to administratively down

L3-SW(config-if-range)#exit

L3-SW(config)#

L2-SW(config)#interface range fastEthernet 0/1-2

L2-SW(config-if-range)#port-group 1

!将端口 Fa0/1~2 加入聚合端口 1,同时创建该聚合端口

L2-SW(config-if-range)#exit

L2-SW(config)#

第三步:将聚合端口设置为 Trunk

L3-SW(config)#interface aggregateport 1

L3-SW(config-if)#switchport mode trunk

L3-SW(config-if)#exit

L3-SW(config)#

L2-SW(config)#interface aggregatePort 1

L2-SW(config-if)#switchport mode trunk

L2-SW(config-if)#exit

L2-SW(config)#

第四步:设置聚合端口的负载平衡方式

L3-SW(config)#aggregateport load-balance ?

!查看交换机支持的负载平衡方式

dst-ip Destination IP address

dst-mac Destination MAC address

ip Source and destination IP address

src-dst-mac Source and destination MAC address

src-ip Source IP address

src-mac Source MAC address

L3-SW(config)#aggregateport load-balance dst-mac

!设置负载平衡方式为依据目的地址进行,默认是依据源和目的地址

L3-SW(config)#exit

L2-SW(config)#aggregatePort load-balance ?

!查看交换机支持的负载平衡方式

dst-mac Destination MAC address

ip Source and destination IP address

src-mac Source MAC address

L2-SW(config)#aggregatePort load-balance dst-mac

!设置负载平衡方式为依据目的地址进行,默认是依据源地址

L2-SW(config)#exit

第五步:查看聚合端口的配置

L3-SW#show aggregatePort load-balance

Load-balance : Destination MAC

L3-SW#

L3-SW#show aggregatePort summary

AggregatePort MaxPorts SwitchPort Mode Ports

------------- -------- ---------- ------ ----------------------------------

Ag1 8 Enabled TRUNK Fa0/1 ,Fa0/2

L3-SW#

L3-SW#show interfaces aggregateport 1

Index(dec):29 (hex):1d

AggregatePort 1 is UP , line protocol is UP

Hardware is Aggregate Link AggregatePort

Interface address is: no ip address

MTU 1500 bytes, BW 1000000 Kbit

Encapsulation protocol is Bridge, loopback not set

Keepalive interval is 10 sec , set

Carrier delay is 2 sec

RXload is 1 ,Txload is 1

Queueing strategy: WFQ

Switchport attributes:

interface's description:""

medium-type is copper

lastchange time:337 Day: 1 Hour: 3 Minute:56 Second

Priority is 0

admin duplex mode is AUTO, oper duplex is Full

admin speed is AUTO, oper speed is 100M

flow control admin status is AUTO,flow control oper status is OFF

broadcast Strom Control is OFF,multicast Strom Control is OFF,unicast Strom

Control is OFF

Aggregate Port Informations:

Aggregate Number: 1

Name: "AggregatePort 1"

Refs: 2

Members: (count=2)

FastEthernet 0/1 Link Status: Up

FastEthernet 0/2 Link Status: Up

L3-SW#

L2-SW#show aggregatePort load-balance

Load-balance : Destination MAC address

L2-SW#

L2-SW#show aggregatePort summary

AggregatePort MaxPorts SwitchPort Mode Ports

------------- -------- ---------- ------ -----------------------

Ag1 8 Enabled Trunk Fa0/1 , Fa0/2

L2-SW#

L2-SW#show interfaces aggregatePort 1

Interface : AggregatePort 1

Description :

AdminStatus : up

OperStatus : up

Hardware : -

Mtu : 1500

LastChange : 0d:0h:0m:0s

AdminDuplex : Auto

OperDuplex : Full

AdminSpeed : Auto

OperSpeed : 100

FlowControlAdminStatus : Off

FlowControlOperStatus : Off

Priority : 0

Broadcast blocked :DISABLE

Unknown multicast blocked :DISABLE

Unknown unicast blocked :DISABLE

L2-SW#

第六步:验证配置

在三层交换机 L3-SW 上配置另一个用于测试的 VLAN 10,配置 IP 地址为

192.168.10.1/24,然后在二层交换机 L2-SW 上配置默认网关(其作用相当于主机的网关,

交换机可将发往其他网段的数据包提交给网关处理),这样 L2-SW 可以 ping 通

192.168.1.1/24 和 192.168.10.1/24,说明聚合端口的 Trunk 配置已经生效。

L3-SW(config)#vlan 10

L3-SW(config-vlan)#exit

L3-SW(config)#

L3-SW(config)#interface vlan 10

L3-SW(config-if)#iDec 3 01:16:02 L3-SW %7:%LINE PROTOCOL CHANGE:

Interface VLAN 10, changed state to UP

L3-SW(config-if)#ip address 192.168.10.1 255.255.255.0

L3-SW(config-if)#no shutdown

L3-SW(config-if)#exit

L2-SW(config)#ip default-gateway 192.168.1.1

!设置二层交换机的默认网关

L2-SW(config)#exit

L2-SW#

L2-SW#ping 192.168.1.1

Sending 5, 100-byte ICMP Echos to 192.168.1.1,

timeout is 2000 milliseconds.

!!!!!

Success rate is 100 percent (5/5)

Minimum = 1ms Maximum = 1ms, Average = 1ms

L2-SW#ping 192.168.10.1

Sending 5, 100-byte ICMP Echos to 192.168.10.1,

timeout is 2000 milliseconds.

!!!!!

Success rate is 100 percent (5/5)

Minimum = 1ms Maximum = 1ms, Average = 1ms

在三层交换机 L3-SW 上长时间的 ping 二层交换机 L2-SW,然后断开聚合端口中的

Fa0/2 端口:

L3-SW#ping 192.168.1.2 ntimes 1000

Sending 1000, 100-byte ICMP Echoes to 192.168.1.2, timeout is 2 seconds:

< press Ctrl+C to break >

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 100 percent (1000/1000), round-trip min/avg/max = 1/1/10 ms

可以看到在断开聚合端口中的 Fa0/2 端口时是没有丢包的。再次实验,此次断开 Fa0/1

端口:

L3-SW#ping 192.168.1.2 ntimes 1000

Sending 1000, 100-byte ICMP Echoes to 192.168.1.2, timeout is 2 seconds:

< press Ctrl+C to break >

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 99 percent (999/1000), round-trip min/avg/max = 1/1/10 ms

发现此时有一个丢包。这说明在实验中设置的负载均衡方式下,同一对源和目的地址之

间的流量只从一个物理端口进行转发,这个端口断开时会将流量切换到另一个端口上,引起

了链路短暂的中断。

【注意事项】

1、只有同类型端口才能聚合为一个 AG 端口。

2、所有物理端口必须属于同一个 VLAN。

3、在锐捷交换机上最多支持 8 个物理端口聚合为一个 AG。

4、在锐捷交换机上最多支持 6 组聚合端口。

【参考配置】

L3-SW#show running-config

Building configuration...

Current configuration : 1378 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 19:51:54 CST 2007 -ubu6server)

hostname L3-SW

!

vlan 1

!

vlan 10

!

interface FastEthernet 0/1

port-group 1

!

interface FastEthernet 0/2

port-group 1

!

interface FastEthernet 0/3

!

interface FastEthernet 0/4

!

interface FastEthernet 0/5

!

interface FastEthernet 0/6

!

interface FastEthernet 0/7

!

interface FastEthernet 0/8

!

interface FastEthernet 0/9

!

interface FastEthernet 0/10

!

interface FastEthernet 0/11

!

interface FastEthernet 0/12

!

interface FastEthernet 0/13

!

interface FastEthernet 0/14

!

interface FastEthernet 0/15

!

interface FastEthernet 0/16

!

interface FastEthernet 0/17

!

interface FastEthernet 0/18

!

interface FastEthernet 0/19

!

interface FastEthernet 0/20

!

interface FastEthernet 0/21

!

interface FastEthernet 0/22

!

interface FastEthernet 0/23

!

interface FastEthernet 0/24

!

interface GigabitEthernet 0/25

!

interface GigabitEthernet 0/26

!

interface GigabitEthernet 0/27

!

interface GigabitEthernet 0/28

!

interface AggregatePort 1

switchport mode trunk

!

interface VLAN 1

ip address 192.168.1.1 255.255.255.0

!

interface VLAN 10

ip address 192.168.10.1 255.255.255.0

!

aggregateport load-balance dst-mac

!

!

line con 0

line vty 0 4

login

!

end

L2-SW#show running-config

System software version : 1.68 Build Apr 25 2007 Release

Building configuration...

Current configuration : 347 bytes

!

version 1.0

!

hostname L2-SW

vlan 1

!

aggregateport load-balance dst-mac

interface aggregatePort 1

switchport mode trunk

!

interface fastEthernet 0/1

port-group 1

!

interface fastEthernet 0/2

port-group 1

!

interface vlan 1

no shutdown

ip address 192.168.1.2 255.255.255.0

!

ip default-gateway 192.168.1.1

end

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消