运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

实验 利用三层交换机实现 VLAN 间路由

运维开发网 https://www.qedev.com 2020-02-17 09:45 出处:网络 作者:wb57ce870a60888
实验 利用三层交换机实现 VLAN 间路由【实验名称】利用三层交换机实现 VLAN 间路由。【实验目的】掌握如何在三层交换机上配置 SVI 端口,实现 VLAN 间的路由。【背景描述】假设某企业有两个主要部门:销售部和技术部,其中销售部门的个人计算机系统分散连接在两台交换机上,他们之间需要相互进行通信,销售部和技术部也需要进行相互通信,现要在交换机上做适当配置来实现这一目标。【需求分析】需要在网络

实验 利用三层交换机实现 VLAN 间路由

【实验名称】

利用三层交换机实现 VLAN 间路由。

【实验目的】

掌握如何在三层交换机上配置 SVI 端口,实现 VLAN 间的路由。

【背景描述】

假设某企业有两个主要部门:销售部和技术部,其中销售部门的个人计算机系统分散连

接在两台交换机上,他们之间需要相互进行通信,销售部和技术部也需要进行相互通信,现

要在交换机上做适当配置来实现这一目标。

【需求分析】

需要在网络内所有的交换机上配置 VLAN,然后在三层交换机上给相应的 VLAN 设置

IP 地址,以实现 VLAN 间的路由。

【实验拓扑】

图 3-10 实验拓扑图

【实验设备】

三层交换机 1 台

二层交换机 1 台

【预备知识】

交换机的基本配置方法,VLAN 的工作原理和配置方法,Trunk 的工作原理和配置方法,

三层交换的工作原理和配置方法

【实验原理】

在交换网络中,通过 VLAN 对一个物理网络进行了逻辑划分,不同的 VLAN 之间是无

法直接访问的,必须通过三层的路由设备进行连接。一般利用路由器或三层交换机来实现不

同 VLAN 之间的互相访问。三层交换机和路由器具备网络层的功能,能够根据数据的 IP 包

头信息,进行选路和转发,从而实现不同网段之间的访问。

直连路由是指:为三层设备的接口配置 IP 地址,并且激活该端口,三层设备会自动产

生该接口 IP 所在网段的直连路由信息。

三层交换机实现 VLAN 互访的原理是,利用三层交换机的路由功能,通过识别数据包

的 IP 地址,查找路由表进行选路转发。三层交换机利用直连路由可以实现不同 VLAN 之间

的互相访问。三层交换机给接口配置 IP 地址,采用 SVI(交换虚拟接口)的方式实现 VLAN

间互连。SVI 是指为交换机中的 VLAN 创建虚拟接口,并且配置 IP 地址。

【实验步骤】

第一步:配置两台交换机的主机名

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname L2-SW

L2-SW(config)#

S3750#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

S3750(config)#hostname L3-SW

L3-SW(config)#

第二步:在三层交换机上划分 VLAN  添加端口,并设置 Trunk

L3-SW(config)#vlan 10

L3-SW(config-vlan)#name xiaoshou

L3-SW(config-vlan)#vlan 20

L3-SW(config-vlan)#name jishu

L3-SW(config-vlan)#exit

L3-SW(config)#

L3-SW(config)#interface range fastEthernet 0/6-10

L3-SW(config-if-range)#switchport mode access

L3-SW(config-if-range)#switchport access vlan 10

L3-SW(config-if-range)#exit

L3-SW(config)#interface range fastEthernet 0/11-15

L3-SW(config-if-range)#switchport mode access

L3-SW(config-if-range)#switchport access vlan 20

L3-SW(config-if-range)#exit

L3-SW(config)#

L3-SW(config)#interface fastEthernet 0/1

L3-SW(config-if)#switchport mode trunk

L3-SW(config-if)#exit

L3-SW(config)#

第三步:在二层交换机上划分 VLAN  添加端口,并设置 Trunk

L2-SW(config)#vlan 10

L2-SW(config-vlan)#name xiaoshou

L2-SW(config-vlan)#vlan 20

L2-SW(config-vlan)#name jishu

L2-SW(config-vlan)#exit

L2-SW(config)#

L2-SW(config)#interface range fastEthernet 0/6-10

L2-SW(config-if-range)#switchport mode access

L2-SW(config-if-range)#switchport access vlan 10

L2-SW(config-if-range)#exit

L2-SW(config)#

L2-SW(config)#interface fastEthernet 0/1

L2-SW(config-if)#switchport mode trunk

L2-SW(config-if)#exit

L2-SW(config)#

第四步:查看 VLAN 和 和 Trunk  的配置

L2-SW#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1 ,Fa0/2 ,Fa0/3

Fa0/4 ,Fa0/5 ,Fa0/11

Fa0/12,Fa0/13,Fa0/14

Fa0/15,Fa0/16,Fa0/17

Fa0/18,Fa0/19,Fa0/20

Fa0/21,Fa0/22,Fa0/23

Fa0/24

10 xiaoshou active Fa0/1 ,Fa0/6 ,Fa0/7

Fa0/8 ,Fa0/9 ,Fa0/10

20 jishu active Fa0/1

L2-SW#

L2-SW#show interfaces fastEthernet 0/1 switchport

Interface Switchport Mode Access Native Protected VLAN lists

---------- ---------- --------- ------- -------- --------- --------------------

Fa0/1 Enabled Trunk 1 1 Disabled All

L3-SW#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -----------------------------------

1 VLAN0001 STATIC Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/16, Fa0/17, Fa0/18

Fa0/19, Fa0/20, Fa0/21, Fa0/22

Fa0/23, Fa0/24, Gi0/25, Gi0/26

Gi0/27, Gi0/28

10 xiaoshou STATIC Fa0/1, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10

20 jishu STATIC Fa0/1, Fa0/11, Fa0/12, Fa0/13

Fa0/14, Fa0/15

L3-SW#

L3-SW#show interfaces fastEthernet 0/1 switchport

Interface Switchport Mode Access Native Protected VLAN

lists

------------------------ ---------- --------- ------ ------ --------- ----------

FastEthernet 0/1 enabled TRUNK 1 1 Disabled ALL

第五步:验证配置

PC3 和 PC1 都属于 VLAN 10,它们的 IP 地址都在 C 类网络 192.168.10.0/24 内,PC2

属于 VLAN 20,它的 IP 地址在 C 类网络 192.168.20.0/24 内,此时,不同 VLAN 之间的

PC3 和 PC2 是不能 ping 通的,如 错误!未找到引用源。所示。

图 3-11 从 PC3 不能 ping 通 PC2

第六步:在三层交换机上配置 SVI  端口

L3-SW#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

L3-SW(config)#interface vlan 10

!激活 VLAN 10 的 SVI 端口并配置 IP 地址

L3-SW(config-if)#Dec 2 18:59:30 L3-SW %7:%LINE PROTOCOL CHANGE:

Interface VLAN 10, changed state to UP

L3-SW(config-if)#ip address 192.168.10.1 255.255.255.0

L3-SW(config-if)#no shutdown

L3-SW(config-if)#exit

L3-SW(config)#

L3-SW(config)#interface vlan 20

!激活 VLAN 20 的 SVI 端口并配置 IP 地址

L3-SW(config-if)#Dec 2 19:00:05 L3-SW %7:%LINE PROTOCOL CHANGE:

Interface VLAN 20, changed state to UP

L3-SW(config-if)#ip address 192.168.20.1 255.255.255.0

L3-SW(config-if)#no shutdown

L3-SW(config-if)#exit

L3-SW(config)#

第七步:查看 SVI  端口的配置

L3-SW#show ip route

Codes: C - connected, S - static, R - RIP B - BGP

O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default

Gateway of last resort is no set

C 192.168.10.0/24 is directly connected, VLAN 10

C 192.168.10.1/32 is local host.

C 192.168.20.0/24 is directly connected, VLAN 20

C 192.168.20.1/32 is local host.

L3-SW#

从中可以看到,VLAN 的虚拟端口上配置的 IP 地址,其网段成为了三层交换机的直连

路由。

L3-SW#show interfaces vlan 10

Index(dec):4106 (hex):100a

VLAN 10 is UP , line protocol is UP

Hardware is VLAN, address is 00d0.f821.a543 (bia 00d0.f821.a543)

Interface address is: 192.168.10.1/24

ARP type: ARPA,ARP Timeout: 3600 seconds

MTU 1500 bytes, BW 1000000 Kbit

Encapsulation protocol is Ethernet-II, loopback not set

Keepalive interval is 10 sec , set

Carrier delay is 2 sec

RXload is 1 ,Txload is 1

Queueing strategy: WFQ

L3-SW#

L3-SW#show interfaces vlan 20

Index(dec):4116 (hex):1014

VLAN 20 is UP , line protocol is UP

Hardware is VLAN, address is 00d0.f821.a543 (bia 00d0.f821.a543)

Interface address is: 192.168.20.1/24

ARP type: ARPA,ARP Timeout: 3600 seconds

MTU 1500 bytes, BW 1000000 Kbit

Encapsulation protocol is Ethernet-II, loopback not set

Keepalive interval is 10 sec , set

Carrier delay is 2 sec

RXload is 1 ,Txload is 1

Queueing strategy: WFQ

L3-SW#

第八步:验证配置

给 PC3 添加网关 192.168.10.1,如 错误!未找到引用源。所示,此时再从 PC3 去 ping

不同 VLAN 的主机 PC2,是可以 ping 通的,如 错误!未找到引用源。所示。

图 3-12 为 PC3 设置网关

图 3-13 设置三层交换机后,PC3 可以 ping 通 PC2

【注意事项】

1、两台交换机之间相连的端口应该设置为 tag vlan 模式。

2、给 SVI 端口设置完 IP 地址后,一定要使用 no shutdown 命令进行激活,否则无法

正常使用。

3、如果 VLAN 内没有激活的端口,相应 VLAN 的 SVI 端口将无法被激活。

4、需要设置 PC 的网关为相应 VLAN 的 SVI 接口地址。

【参考配置】

L3-SW#show running-config

Building configuration...

Current configuration : 1605 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 19:51:54 CST 2007 -ubu6server)

hostname L3-SW

!

vlan 1

!

vlan 10

name xiaoshou

!

vlan 20

name jishu

!

!

interface FastEthernet 0/1

switchport mode trunk

!

interface FastEthernet 0/2

!

interface FastEthernet 0/3

!

interface FastEthernet 0/4

!

interface FastEthernet 0/5

!

interface FastEthernet 0/6

switchport access vlan 10

!

interface FastEthernet 0/7

switchport access vlan 10

!

interface FastEthernet 0/8

switchport access vlan 10

!

interface FastEthernet 0/9

switchport access vlan 10

!

interface FastEthernet 0/10

switchport access vlan 10

!

interface FastEthernet 0/11

switchport access vlan 20

!

interface FastEthernet 0/12

switchport access vlan 20

!

interface FastEthernet 0/13

switchport access vlan 20

!

interface FastEthernet 0/14

switchport access vlan 20

!

interface FastEthernet 0/15

switchport access vlan 20

!

interface FastEthernet 0/16

!

interface FastEthernet 0/17

!

interface FastEthernet 0/18

!

interface FastEthernet 0/19

!

interface FastEthernet 0/20

!

interface FastEthernet 0/21

!

interface FastEthernet 0/22

!

interface FastEthernet 0/23

实验 利用三层交换机实现 VLAN 间路由

实验 利用三层交换机实现 VLAN 间路由

实验 利用三层交换机实现 VLAN 间路由

!

interface FastEthernet 0/24

!

interface GigabitEthernet 0/25

!

interface GigabitEthernet 0/26

!

interface GigabitEthernet 0/27

!

interface GigabitEthernet 0/28

!

interface VLAN 10

ip address 192.168.10.1 255.255.255.0

!

interface VLAN 20

ip address 192.168.20.1 255.255.255.0

!

!

line con 0

line vty 0 4

login

!

end

L2-SW#show running-config

System software version : 1.68 Build Apr 25 2007 Release

Building configuration...

Current configuration : 457 bytes

!

version 1.0

!

hostname L2-SW

vlan 1

!

vlan 10

name xiaoshou

!

vlan 20

name jishu

!

interface fastEthernet 0/1

switchport mode trunk

!

interface fastEthernet 0/6

switchport access vlan 10

!

interface fastEthernet 0/7

switchport access vlan 10

!

interface fastEthernet 0/8

switchport access vlan 10

!

interface fastEthernet 0/9

switchport access vlan 10

!

interface fastEthernet 0/10

switchport access vlan 10

!

end

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消