运维开发网

anaconda升级sklearn版本的实现方法

运维开发网 https://www.qedev.com 2021-02-25 11:15 出处:网络 作者: bitcarmanlee
调用sklearn的model_selection时,发现sklearn中没有model_selection的模块。经过检查,发现anaconda中的sklearn版本太低,为0.17版本。于是,开始了sklearn的升级之旅。

调用sklearn的model_selection时,发现sklearn中没有model_selection的模块。经过检查,发现anaconda中的sklearn版本太低,为0.17版本。于是,开始了sklearn的升级之旅。

1.查看原有版本

首先使用conda list命令,查看一下现有的版本:

anaconda升级sklearn版本的实现方法

果不其然,版本是0.17.1,版本太低,果断开始升级。

2.升级到最新版本

使用conda update scikit-learn命令,更新sklearn的版本。更新之前,会提示将更新到什么版本。

anaconda升级sklearn版本的实现方法

可以看出最新的版本为0.19.0

然后确认,开始更新。

anaconda升级sklearn版本的实现方法

由于此次更新需要更新的包很多,并且很大,所以需要等相当长的时间。。。

等更新完毕以后,再使用model_selection包,就OK了

到此这篇关于anaconda升级sklearn版本的实现方法的文章就介绍到这了,更多相关anaconda升级sklearn版本内容请搜索我们以前的文章或继续浏览下面的相关文章希望大家以后多多支持我们!

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号