运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

在Ubuntu Kylin 20.04 pro中安装CrossOver微信及QQ失败的解决

运维开发网 https://www.qedev.com 2021-05-17 10:06 出处:ubuntukylin站 作者:lmy
如果你在优麒麟Ubuntu Kylin 20.04 pro中用麒麟软件商店安装CrossOver微信及QQ,却出现安装CrossOver微信及QQ失败的情况,请用下面的方法解决。 解决方法 第一步需要安装依赖,把高版本的包降

如果你在优麒麟Ubuntu Kylin 20.04 pro中用麒麟软件商店安装CrossOver微信及QQ,却出现安装CrossOver微信及QQ失败的情况,请用下面的方法解决。

 

解决方法

第一步需要安装依赖,把高版本的包降级到源里正常版本的包,以便CrossOver微信、QQ正常安装,请打开终端,运行以下命令:

sudo apt install libc6=2.31-0ubuntu9.2 libc6:i386=2.31-0ubuntu9.2 libc6-dbg=2.31-0ubuntu9.2 libc6-dev=2.31-0ubuntu9.2 libc-dev-bin:i386 llibc-dev-bin=2.31-0ubuntu9.2

第二步打开麒麟软件商店,点击安装CrossOver微信、QQ,如下图所示:

在Ubuntu Kylin 20.04 pro中安装CrossOver微信及QQ失败的解决

参考:在优麒麟Ubuntu Kylin上安装微信(CrossOver版)和QQ(CrossOver版)。

 

附1:解决商店里的CrossOver微信、QQ下载失败,请重试(错误码#0002)

错误截图如下:

在Ubuntu Kylin 20.04 pro中安装CrossOver微信及QQ失败的解决

遇到这种情况,可把软件更新器里的“源代码”和“提前释放出的更新”勾上,然后更新重启后就可以安装了,如下图:

在Ubuntu Kylin 20.04 pro中安装CrossOver微信及QQ失败的解决

在Ubuntu Kylin 20.04 pro中安装CrossOver微信及QQ失败的解决

 

附2:Crossover微信无法安装的解决一例

在优麒麟Ubuntu Kylin 20.04 pro系统中无法安装Crossover版微信,用apt install cxwechat,报依赖错误:

下列软件包有未满足的依赖关系:

cxwechat : 依赖: gstreamer1.0-plugins-good:i386

依赖: libcups2:i386

依赖: libgnutls30:i386

依赖: libldap-2.4-2:i386

依赖: libsane:i386

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决方案:出现以上问题可先更新系统,把系统更新完成后再去安装。有条件的用户可在安装Ubuntu Kylin 20.04 pro系统时连接wifi网络,然后勾选安装更新,这样能减少有依赖问题出现。

 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号