运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

Deepin 20.2系统下Qt打不开,找不到libxcb-util.so.1的解决

运维开发网 https://www.qedev.com 2021-04-29 10:15 出处:深度站 作者:as-xiongshijie
在Deepin 20.2系统出现Qt打不开的情况,有提示libxcb-util.so.1 not found的解决。 说明 修改配置文件~/.bashrc: $ vim ~/.bashrc 参考: 什么是bashrc配置文件,如何对其进行编辑 。 在最末尾添加如下

在Deepin 20.2系统出现Qt打不开的情况,有提示libxcb-util.so.1 not found的解决。

 

说明

修改配置文件~/.bashrc:

$ vim ~/.bashrc

参考:什么是bashrc配置文件,如何对其进行编辑。

在最末尾添加如下语句,会在qtcreator启动时,列出详细的错误提示:

export

QT_DEBUG_PLUGINS=1

注:可采用同一行,即export  QT_DEBUG_PLUGINS=1。

然后出现:

Deepin 20.2系统下Qt打不开,找不到libxcb-util.so.1的解决

发现是少东西,可是我在安装之后是可以正常打开的,还不知道为啥这个突然就没了:

Deepin 20.2系统下Qt打不开,找不到libxcb-util.so.1的解决

 

解决方法

经过调查之后发现问题出在QT,需要手动下载一个包安装之后才能解决:

Deepin 20.2系统下Qt打不开,找不到libxcb-util.so.1的解决

libxcb-util1_0.4.0-1+b1_amd64.deb包的下载地址是:https://packages.debian.org/bullseye/amd64/libxcb-util1/download

用上后Qt就可以正常运行了。

 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号