运维开发网

升级Deepin遇到未满足依赖openjdk-11-jdk-headless的解决

运维开发网 https://www.qedev.com 2021-04-13 10:11 出处:深度站 作者:youxiangyang
在升级Deepin系统的过程中,遇到openjdk-11-jdk-headless及org.jkiss.dbeaver-ee软件包有未满足的依赖关系,以下是解决方案。 出现错误的过程 因为看到Deepin系统有出新版本,所以想升级。然后,

在升级Deepin系统的过程中,遇到openjdk-11-jdk-headless及org.jkiss.dbeaver-ee软件包有未满足的依赖关系,以下是解决方案。

 

出现错误的过程

因为看到Deepin系统有出新版本,所以想升级。然后,升级界面无法升级,最后就试试命令行升级。但是提示有为满足的依赖关系,如下图:

升级Deepin遇到未满足依赖openjdk-11-jdk-headless的解决

目前试了几个办法,但是都没有成功:

1、执行apt --fix-broken install命令,最后会发生下面的问题,如下图:

升级Deepin遇到未满足依赖openjdk-11-jdk-headless的解决

2、感觉好像是安装了DBeaver后,它可能需要jdk-11方面的依赖,但是系统已经安装了openjdk-8,然后可能影响了升级。当然,DBeaver是可以用的,于是就准备卸载DBeaver,结果是,卸载不了,会有上面类似依赖关系不满足的错误提示。

3、卸载jdk-8,安装jdk-11,不过卸载不了openjdk-8,也是提示依赖不满足,同时jdk-11也安装不了。

4、尝试了一个覆盖default.jfc的命令,没有成功。

注:感觉罪魁祸首是从应用商店安装的DBeaver(深度商店应用SmartSynchronize、DBeaver EE、Unity3D、PhpStorm)。经过上面的折腾后,应用商店不能用了,可以打开页面,但是安装、卸载功能都不可以用。不过还可以安装软件,只是不能用应用商店了。

 

找到的原因和解决方案

以上问题应该是出在jdk方面,但是升级到jdk11遇到的问题,试了好几次,都是说有一个东西覆盖失败啥的,最后采用强制安装openjdk11(请参考以下截图),采用--force-overwrite标志后意外的可以了:

sudo dpkg -i --force-overwrite '/var/cache/apt/archives/openjdk-11-jdk_11~b114-0ubuntu1_amd64.deb'

附:以上解决方案参考以下截图内容

升级Deepin遇到未满足依赖openjdk-11-jdk-headless的解决

 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号