运维开发网

centos6.8 update centos7.2

运维开发网 https://www.qedev.com 2021-04-07 23:10 出处:51CTO 作者:麻辣虾球
1. 升级当前系统到最新版本:yum update -y2. 安装旧版openscap: yum remove -y openscap && yum install -y http://buildlogs.centos.org/centos/6/upg/x86_64/Packages/openscap-1.0.8-1.0.1.el6.centos.x86_64.rpm3.添加upg

1. 升级当前系统到最新版本:yum update -y

2. 安装旧版openscap: yum remove -y openscap && yum install -y http://buildlogs.centos.org/centos/6/upg/x86_64/Packages/openscap-1.0.8-1.0.1.el6.centos.x86_64.rpm

3.添加upgradetool源:

cat <<EOF >/etc/yum.repos.d/upgradetool.repo[upgrade]name=CentOS-$releasever - Upgrade Toolbaseurl=http://buildlogs.centos.org/centos/6/upg/x86_64/gpgcheck=1enabled=1gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6EOF

4.安装升级工具:yum install -y redhat-upgrade-tool preupgrade-assistant preupgrade-assistant-contents;

5. 执行升级可行性分析:preupg,该命令会耗费几分钟到几十分钟时间。如果出现preupg: error: [Errno 2] No such file or directory: '/root/preupgrade/result.html'的错误,请参考第一步安装openscap的旧版;

6. 使用清华大学的centos-vault源安装7.2版本:

centos-upgrade-tool-cli --network 7 --instrepo=https://mirrors.tuna.tsinghua.edu.cn/centos-vault/7.2.1511/os/x86_64/。

注意:7.2是支持升级的最高版本,升级其他版本将会出现Downloading failed: invalid data in .treeinfo: No section: 'checksums'的错误提示;

7. 如果升级成功,用reboot命令重启系统;如果提示The requested URL returned error: 404 Not Found等错误,基本上说明当前系统不支持直接升级。果断采用重装系统的正道吧,少年!

8. 系统重启后,有可能因为依赖库确实导致ssh无法启动,grep不能正常使用等问题。基本功底够好的手动排查,然后一个个问题解决;搞不懂错误原因或者觉得处理麻烦的,备份数据后重装系统吧!

9. 使用rpm -qa | grep el6查看系统上残留的软件包。如果能手动清理掉,让系统update无障碍,耐心一个个处理掉。如果觉得依赖太麻烦或者搞不定,备份数据后重装系统吧!

10.升级系统后sshd服务无法启动 。

ln -s libsasl2.so.3.0.0 libsasl2.so.2

ln -s /usr/lib64/libpcre.so /usr/lib64/libpcre.so.0

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号