运维开发网

在Deepin 20/UOS下安装Wine 6.0稳定版的方法及报错的解决

运维开发网 https://www.qedev.com 2021-03-03 10:00 出处:深度站 作者:huar
以下介绍在Deepin 20系统下安装Wine 6.0稳定版的方法,也可适用在UOS系统上。由于Deepin 20是基于Debian的,所以添加Debian 10(Buster)的Wine仓库,按照Wine官方的文档操作即可,但在最后一步可能

以下介绍在Deepin 20系统下安装Wine 6.0稳定版的方法,也可适用在UOS系统上。由于Deepin 20是基于Debian的,所以添加Debian 10(Buster)的Wine仓库,按照Wine官方的文档操作即可,但在最后一步可能会报错。

在Deepin 20/UOS下安装Wine 6.0稳定版的方法及报错的解决

 

安装Wine 6.0稳定版需要依次运行的命令

请先看安装WineHQ安装包的官方技术截图:

在Deepin 20/UOS下安装Wine 6.0稳定版的方法及报错的解决

需要依次运行的命令:

sudo dpkg --add-architecture i386

wget -nc https://dl.winehq.org/wine-builds/Release.key

sudo apt-key add Release.key

然后将软件源添加到/etc/apt/sources.list:

deb https://dl.winehq.org/wine-builds/debian/ buster main

最后运行:

sudo apt update

sudo apt install --install-recommends winehq-stable

附:关于Wine 6.0的更新内容,请看Wine 6.0发布下载,附Wine 6.0新功能介绍。

 

最后一步报错的解决方法

报错:

winehq-stable : 依赖: wine-stable

开始解决错误:

sudo apt-get install aptitude ##安装aptitude来解决依赖的问题

sudo aptitude install wine-stable

按Y键,什么也没操作。

手动安装:

sudo apt-get install wine-stable-amd64

报错,解决依赖,下面需要下载libfaudio0_20.01-0_buster_i386.deb。

下载地址:https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/i386/

下载libfaudio0_20.01-0~buster_i386.deb,大小是138K,双击安装:

在Deepin 20/UOS下安装Wine 6.0稳定版的方法及报错的解决

不过双击安装上面的.deb时报错,报缺少依赖,在这个.deb安装包右下角会出现红字(缺少依赖的文件名)。

libstb0:i386用aptitude来修复依赖:

sudo aptitude install libstb0:i386

sudo aptitude install 上面红字的全名

然后看到,aptitude解决依赖问题。继续双击安装libfaudio0_20.01-0_buster_i386.deb。

sudo apt-get install wine-stable-amd64

这个过程超慢,等吧。最后再执行,安装Wine 6.0的最后一步:

sudo apt install --install-recommends winehq-stable

 

说明

libfaudio0这个如果需要新版本的话,可以在Debian buster-backports仓库里下载到新版本的。

经过测试,Wine 6.0能玩不少的游戏,比如能玩英雄无敌3了,以前用Wine 5能玩的星际争霸1.08现在也能玩。

 

附:加速技巧

安装Wine其实可以非常快,需要安装lantern。

编写配置文件到/etc/apt/apt.conf.d/,就可以使用lantern实现加速,34847改成你自己的端口号。

~ cat ~/.bin/lantern.conf

Acquire::http::proxy "http://127.0.0.1:34847";

~ sudo cp ~/.bin/lantern.conf /etc/apt/apt.conf.d/

 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号