运维开发网

在Deepin V20/Ubuntu 20.04下安装佳能LBP2900+打印机的方法

运维开发网 https://www.qedev.com 2021-02-21 10:18 出处:深度站 作者:jjcui8595
本文为你介绍在Deepin V20系统下安装佳能LBP2900+打印机的方法,同样的方法也适用在Ubuntu 20.04下,但在Ubuntu下需要安装canberra-gtk-module。 在Deepin V20下安装LBP2900+打印机 在Deepin V20系统下安装

本文为你介绍在Deepin V20系统下安装佳能LBP2900+打印机的方法,同样的方法也适用在Ubuntu 20.04下,但在Ubuntu下需要安装canberra-gtk-module。

在Deepin V20/Ubuntu 20.04下安装佳能LBP2900+打印机的方法

 

在Deepin V20下安装LBP2900+打印机

在Deepin V20系统下安装LBP2900+打印机时,会出现“lpadmin:打印机驱动已被弃用,未来的CUPS版本可能破坏其功能性”的提示,不能正常打印测试页。作为Linux新手,查找很多资料后发现,问题主要在于佳能64位打印机驱动程序依赖很多32位库文件,安装后即可解决。

具体步骤如下:

1、sudo apt-get install libglade2-0:amd64 #如果不安装此库文件,则第2步无法进行

2、sudo dpkg -i cndrvcups-common_3.21-1_amd64.deb

3、sudo dpkg -i cndrvcups-capt_2.71-1_amd64.deb #第2、3步安装佳能64位驱动程序

4、sudo apt-get install libpopt0:i386 #安装64位Canon CAPT打印机驱动程序包括专有的闭源32位可执行捕获筛选器所需的32位库文件

5、sudo apt-get install zlib1g:i386 libxml2:i386 libstdc++6:i386 #安装其他依赖的32位库文件,也可以安装libpopt0:i386,它会自动安装前边的3个文件

6、sudo /usr/sbin/lpadmin -p LBP3000 -m CNCUPSLBP3000CAPTK.ppd -v ccp://localhost:59787 -E #仍会出现lpadmin驱动被弃用的提示,不用管它

7、sudo /usr/sbin/ccpdadmin -p LBP3000 -o /dev/usb/lp0 #注册使用ccpd守护进程,注意查看自己的打印机是否是lp0,如果是lp1则改成对照的

8、sudo /etc/init.d/ccpd start #启动ccpd守护进程

通过以上步骤,打印机就安装、配置完成了。

参考:总结各大常见打印机品牌在Linux下的驱动方法。

 

注意事项

执行captstatusui -P LBP3000,如果弹出窗口内显示"Ready to Print",说明打印机已经就绪。

如果提示错误,执行sudo /etc/init.d/ccpd restart,重启ccpd进程。

 

在Ubuntu 20.04下的注意事项

上面同样的方法也适于在Ubuntu 20.04系统下,但在Ubuntu中还需要安装canberra-gtk-module,在终端中运行以下命令即可:

sudo apt-get install libcanberra-gtk-module

 

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号