运维开发网

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

运维开发网 https://www.qedev.com 2021-01-31 19:13 出处:云网牛站 作者:吴析
本文介绍在CentOS 8/CentOS 7操作系统上安装Metasploit框架(Metasploit Framework)的方法、和更新Metasploit框架。 在CentOS 8/CentOS 7上安装Metasploit框架(Metasploit Framework) 安装方法非常的简单,先使

本文介绍在CentOS 8/CentOS 7操作系统上安装Metasploit框架(Metasploit Framework)的方法、和更新Metasploit框架。

 

在CentOS 8/CentOS 7上安装Metasploit框架(Metasploit Framework)

安装方法非常的简单,先使用wget或curl命令下载Metasploit Framework安装程序,如果还没有安装curl可以参考在CentOS 8发行版上安装Curl的方法:

curl https://raw.githubusercontent.com/rapid7/metasploit-omnibus/master/config/templates/metasploit-framework-wrappers/msfupdate.erb > msfinstall

然后运行以下命令以能够安装脚本:

chmod +x msfinstall

接下来执行脚本安装程序即可:

$ ./msfinstall

它会自动安装Metasploit Framework,输出信息如下:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

安装程序脚本会将Metasploit Framework存储库添加到您的存储库列表中,并安装所需的所有工具。请耐心等待执行完毕即可,如果您的网速比较慢,那会需要一段时间,如果网速较快,很快就自动处理完成了。

上面的完成后运行命令以开始初始设置:

$ msfdb init

输出信息如下:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

存储配置输出中显示的MSF Web服务凭据:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

这个时候就能完成Metasploit Framework的安装,会出现如下图所示画面:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

然后用以下命令检查安装的Framework版本:

$ msfconsole --version

本次安装的版本是:

Framework Version: 5.0.77-dev-

 

启动msfconsole

现在数据库已初始化,您可以启动msfconsole了:

$ msfconsole

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

如下所示,使用db_status命令验证数据库的连接性:

$ db_status

结果如下图所示:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

 

更新Metasploit Framework的方法

要更新您的Metasploit框架,请运行以下命令:

$ msfupdate

以下是执行这个命令的返回结果:

在CentOS 8/CentOS 7上安装和更新Metasploit框架的方法

大致意思是正在检查并安装更新,Metasploit-framework添加到您的存储库列表,软件包metasploit-framework-5.0.77+20200224112600~1rapid7-1.el6.x86_64已经安装。

 

0

精彩评论

暂无评论...
验证码 换一张
取 消