运维开发网

centos7下升级git版本

运维开发网 https://www.qedev.com 2021-01-30 12:35 出处:51CTO 作者:测试生财
背景编译EMQX插件依赖了git的版本,需要使用1.8.5以上的版本,但是我系统(centos7)中的版本为1.8.3,不符合版本要求,如下图安装过程1. 卸载旧版本yum -y remove git2. 安装依赖sudo yum install -y curl-devel expat-devel gettext-devel openssl-devel zlib-devel asciidoc  g

背景

编译EMQX插件依赖了git的版本,需要使用1.8.5以上的版本,但是我系统(centos7)中的版本为1.8.3,不符合版本要求,如下图

centos7下升级git版本

安装过程

1. 卸载旧版本

yum -y remove git

2. 安装依赖

sudo yum install -y curl-devel expat-devel gettext-devel openssl-devel zlib-devel asciidoc  gcc perl-ExtUtils-MakeMaker

3. 选择版本

git源码包地址:https://mirrors.edge.kernel.org/pub/software/scm/git/

我们选择一个tar.gz结尾的安装包,例如:git-2.23.0.tar.gz

centos7下升级git版本

4. 下载&解压git源码包

cd /opt && wget https://mirrors.edge.kernel.org/pub/software/scm/git/git-2.23.0.tar.gz && tar -xzvf git-2.23.0.tar.gz

5. 编译&安装

cd git-2.23.0/ &&  make prefix=/usr/local/git all && make prefix=/usr/local/git install

6. 配置环境变量

echo "export PATH=$PATH:/usr/local/git/bin" >> .~/.bashrc

7. 加载环境变量

source ~/.bashrc

8. 验证git版本

执行:git --version,如下图:

centos7下升级git版本

博主:测试生财

座右铭:专注测试与自动化,致力提高研发效能;通过测试精进完成原始积累,通过读书理财奔向财务自由。

csdn:https://blog.csdn.net/ccgshigao

博客园:https://www.cnblogs.com/qa-freeroad/

51cto:https://blog.51cto.com/14900374

0

精彩评论

暂无评论...
验证码 换一张
取 消