运维开发网

ansible运行报错CryptographyDeprecationWarning解决

运维开发网 https://www.qedev.com 2020-09-12 13:01 出处:51CTO 作者:loong576
ansible运行报错:CryptographyDeprecationWarning,本文旨在解决该问题。

前言:ansible运行报错

/usr/lib64/python2.7/site-packages/cryptography/__init__.py:39: CryptographyDeprecationWarning: Python 2 is no longer supported by the Python core team. Support for it is now deprecated in cryptography, and will be removed in a future release.
  CryptographyDeprecationWarning

环境说明:

主机名 操作系统版本 python版本 python3版本 pip版本 pip3版本
ansible Centos 7.6.1810 Python 2.7.5 Python 3.6.8 pip 20.2.2(python 2.7) pip 20.2.2(python 3.6)

一、安装ansible

[[email protected] ~]# yum -y install https://releases.ansible.com/ansible/rpm/release/epel-7-x86_64/ansible-2.9.9-1.el7.ans.noarch.rpm 

ansible运行报错CryptographyDeprecationWarning解决

使用yum方式安装ansible,指定安装ansible版本为2.9.9

二、运行ansible

运行ansible时有如下提示

[[email protected] ~]# ansible --version
/usr/lib64/python2.7/site-packages/cryptography/__init__.py:39: CryptographyDeprecationWarning: Python 2 is no longer supported by the Python core team. Support for it is now deprecated in cryptography, and will be removed in a future release.
  CryptographyDeprecationWarning,
ansible 2.9.10
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Apr  2 2020, 13:16:51) [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]

ansible运行报错CryptographyDeprecationWarning解决

虽然这个提示不影响使用,但是对于有强迫症的我来说是不可接受的

三、问题解决

1.卸载ansible

[[email protected] ~]# yum remove ansible

ansible运行报错CryptographyDeprecationWarning解决

2.使用pip3重新安装ansible

[[email protected] ~]# pip3 install xlrd -i http://pypi.douban.com/simple --trusted-host pypi.douban.com
[[email protected] ~]# mkdir ~/.pip
[[email protected] ~]# touch ~/.pip/pip.conf
[[email protected] .pip]# more pip.conf 
[global]
index-url = http://pypi.douban.com/simple
[install]
trusted-host = pypi.douban.com
[[email protected] .pip]# pip3 install ansible==2.9.9

ansible运行报错CryptographyDeprecationWarning解决

使用pip3重新安装ansible,重装后问题解决

 

 

更多请点击:ansible系列文章

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号