运维开发网

WDCP3.3中多PHP版本安装方法,以及安装遇到的问题

运维开发网 https://www.qedev.com 2020-07-13 15:57 出处:网络
【多版本php安装】 安装方法如下: wget http://down.wdlinux.cn/in/phps.sh sh phps.sh (共支持8个版本的PHP,如5.2.17/5.3.29/5.4.45/5.5.38/5.6.30/7.0/7.2/7.3)

【多版本php安装】

安装方法如下:

wget http://down.wdLinux.cn/in/phps.sh
sh phps.sh

(共支持8个版本的PHP,如5.2.17/5.3.29/5.4.45/5.5.38/5.6.30/7.0/7.2/7.3)

可直接执行

sh phps.php

会提示相应的版本选择安装或安装全部

也可以针对或指定某个版本,如

sh phps.sh 7.1.4

即可安装7.1.4

多版本PHP的手动启动|停止|重起

如:5.5

/www/wdLinux/phps/55/bin/php-fpm start
/www/wdLinux/phps/55/bin/php-fpm stop
/www/wdLinux/phps/55/bin/php-fpm restart

如是其它版本,把55替换为相应版本即可

如无特别求,可不必全部安装或启动,因为启动多一个,就会占资源多一份

已知问题

CentOS 7.X系列系统,不再支持php-5.2/5.3的老版本PHP,可考虑使用CentOS 6.X

 


 

【wdcp安装多版本php环境报错的解决方法】

wdcp推出了多版本php共存的功能,还是很实用的,于是赶紧先升级到wdcp最新版,升级好之后,登录ssh,下载最新版的wdcp安装包,解压,运行sh lib/phps.sh,结果却报gcc: Permission denied错误,php5.2.17无法安装

有人说是云锁的问题,因为云锁上毕竟设置了很多东西,不想写在,于是systemctl stop yunsuo.service(笔者是centos 7的系统,如果是centos7之前的系统,运行service yunsuo stop)。

 

无奈,尝试卸载云锁:

/usr/local/yunsuo_agent/uninstall

 

重新来到wdcp下载目录,

sh lib/phps.sh

顺利编译。

0

精彩评论

暂无评论...
验证码 换一张
取 消