运维开发网

Ubuntu16.04 RYU安装过程出现的问题

运维开发网 https://www.qedev.com 2020-05-19 08:47 出处:网络 作者:运维开发网整理
安装方法 sudo apt install gcc python-dev libffi-dev libssl-dev libxml2-dev libxslt1-dev zlib1g-dev mkdir RYU cd RYU sudo pip install ryu 安装到中途报错了,提示是pip版本较低,根据提示升级后,重新运行su

安装方法

sudo apt install gcc python-dev libffi-dev libssl-dev libxml2-dev libxslt1-dev zlib1g-dev

mkdir RYU

cd RYU

sudo pip install ryu

安装到中途报错了,提示是pip版本较低,根据提示升级后,重新运行sudo pip install ryu,就出现了报错

Traceback (most recent call last):

File "/usr/local/bin/pip", line 7, in

from pip._internal.main import main

ImportError: No module named _internal.main

但是升级以后版本仍然没有变化,在下图其实也能发现,更新pip后还是提示8.1版本。。。。。

Ubuntu16.04 RYU安装过程出现的问题

去网上查了一下,发现可能是pip版本升级后仍然识别到旧版本

但是该方法此时并没有解决我的问题。

一顿折腾,最后找到了,删除旧版本的pip,再用wget安装

pip版本更新失败

更新后pip运行出问题

成功更新pip版本

Ubuntu16.04 RYU安装过程出现的问题

再次安装ryu,没遇到报错了

0

精彩评论

暂无评论...
验证码 换一张
取 消