运维开发网

在CentOS 6.6上使用xterm_clipboard编译vim

运维开发网 https://www.qedev.com 2020-05-16 09:34 出处:网络 作者:运维开发网整理
我有一个最小安装的CentOS 6.6,之后添加了Desktop.我想用xterm_clipboard编译最新的
我有一个最小安装的CentOS 6.6,之后添加了Desktop.我想用xterm_clipboard编译最新的 vim.

我做了以下

>已安装* -devel包

yum install ruby perl-devel python-devel ruby-devel \
  perl-ExtUtils-Embed ncurses-devel libX11 libX11-devel \
  libXtst-devel libXtst libXt-devel libXt libSM-devel libSM \
  libXpm libXpm-devel

那没用.

>接下来我尝试使用groupinstall

yum groupinstall "Desktop" "Desktop Platform" "X Window System" \
  "Fonts" "General Purpose Desktop"

也没有运气.

完成上述每个步骤后,我做到了

make clean

./configure --with-features=huge --enable-perlinterp \
  --enable-rubyinterp --enable-pythoninterp --with-x=yes \
  --enable-gui=auto

然后

grep X11 src/auto/config.h

但每次我看到

/* #undef HAVE_X11 */

强制sudo make install,然后vim –version确认我没有xterm_clipboard(输出显示-xterm_clipboard).

你能帮帮我吗?

谢谢!

我的问题的解决方案是

make distclean
./configure ...

我只是在安装组和各种包之后才进行清理.它不够“干净”,配置文件没有完全恢复到初始状态.

我希望这可以帮助其他人解决同样的问题.

0

精彩评论

暂无评论...
验证码 换一张
取 消