运维开发网

无法在CentOS 7上安装Varnish

运维开发网 https://www.qedev.com 2020-05-10 10:37 出处:网络 作者:运维开发网整理
我想在CentOS 7上安装Varnish 4. 我首先添加了这些rpm: sudo rpm -ivh http://dl.fedoraproject.org/pub/epel/6/x86_64/jemalloc-3.6.0-1.el6.x86_64.rpm
我想在CentOS 7上安装Varnish 4.

我首先添加了这些rpm:

sudo rpm -ivh http://dl.fedoraproject.org/pub/epel/6/x86_64/jemalloc-3.6.0-1.el6.x86_64.rpm
sudo rpm -iUvh http://195.220.108.108/Linux/centos/7.0.1406/extras/x86_64/Packages/epel-release-7-2.noarch.rpm

yum install varnish

但我明白了:

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.team-cymru.org
 * epel: mirror.steadfast.net
 * extras: mirror.team-cymru.org
 * updates: mirror.team-cymru.org
Resolving Dependencies
--> Running transaction check
---> Package varnish.x86_64 0:4.0.2-1.el6 will be installed
--> Processing Dependency: varnish-libs = 4.0.2-1.el6 for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishapi.so.1(LIBVARNISHAPI_1.3)(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishapi.so.1(LIBVARNISHAPI_1.2)(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishapi.so.1(LIBVARNISHAPI_1.0)(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishapi.so.1(LIBVARNISHAPI_1.1)(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishapi.so.1()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libpcre.so.0()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvcc.so()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnishcompat.so()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvarnish.so()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Processing Dependency: libvgz.so()(64bit) for package: varnish-4.0.2-1.el6.x86_64
--> Running transaction check
---> Package varnish.x86_64 0:4.0.2-1.el6 will be installed
--> Processing Dependency: libpcre.so.0()(64bit) for package: varnish-4.0.2-1.el6.x86_64
---> Package varnish-libs.x86_64 0:4.0.2-1.el6 will be installed
--> Processing Dependency: libpcre.so.0()(64bit) for package: varnish-libs-4.0.2-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: varnish-libs-4.0.2-1.el6.x86_64 (varnish-4.0)
           Requires: libpcre.so.0()(64bit)
           Available: varnish-4.0.0-0.20131129tp1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.0-0.20140328beta1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.0-1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-0.20131129tp1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-0.20140328beta1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.1-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-4.0.1-2.el7.x86_64 (epel)
               Not found
           Installing: varnish-4.0.2-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-libs-4.0.1-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-libs-4.0.1-2.el7.x86_64 (epel)
               Not found
           Installing: varnish-libs-4.0.2-1.el6.x86_64 (varnish-4.0)
               Not found
Error: Package: varnish-4.0.2-1.el6.x86_64 (varnish-4.0)
           Requires: libpcre.so.0()(64bit)
           Available: varnish-4.0.0-0.20131129tp1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.0-0.20140328beta1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.0-1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-0.20131129tp1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-0.20140328beta1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-libs-4.0.0-1.el6.x86_64 (varnish-4.0)
               libpcre.so.0()(64bit)
           Available: varnish-4.0.1-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-4.0.1-2.el7.x86_64 (epel)
               Not found
           Installing: varnish-4.0.2-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-libs-4.0.1-1.el6.x86_64 (varnish-4.0)
               Not found
           Available: varnish-libs-4.0.1-2.el7.x86_64 (epel)
               Not found
           Installing: varnish-libs-4.0.2-1.el6.x86_64 (varnish-4.0)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
我不知道你关注的是谁的指示,但指令是错误的,或者他们是错误的指示.

在干净的CentOS 7系统上,您可以通过以下方式安装Varnish 4:

yum install epel-release
yum install varnish

由于您的系统不再干净,您必须先清理它.特别是:

>您安装了EL6的jemalloc软件包.您需要将其替换为EL7.由于您已经安装了EPEL repo,因此应该足够:

yum update jemalloc

否则只需删除并重新安装即可.

rpm --nodeps -e jemalloc
yum install jemalloc

>您从某个地方(可能是Varnish Community)安装了名为varnish-4.0的存储库,但您没有提到这一点.你需要删除它,因为(a)它只用于EL6,(b)EPEL已经发布了Varnish 4.

rpm --nodeps -e $(rpm -qf /etc/yum.repos.d/varnish*.repo)

>最后你的系统应该干净,你可以安装Varnish.

yum install varnish

最后一点:EPEL Varnish将追溯EPEL’s enterprise QA requirements上游的Varnish点发布.如果跟踪点发布对您很重要,您可能希望参加EPEL中此包的QA process.这通常涉及构建或安装测试包,然后根据它是否有效来执行voting it up or down. (例如,在撰写本文时,Varnish 4.0.2是最新的上游版本,它需要另外3个upvotes才能在EPEL中升级到稳定版.)

0

精彩评论

暂无评论...
验证码 换一张
取 消