运维开发网

centos6 – centos 6 epel替代存储库替换

运维开发网 https://www.qedev.com 2020-05-10 10:04 出处:网络 作者:运维开发网整理
我已经在我的服务器上安装了EPEL存储库.我想安装新的东西,我用yum得到这个错误:
我已经在我的服务器上安装了EPEL存储库.我想安装新的东西,我用yum得到这个错误:

PYCURL ERROR 22 – “请求的URL返回错误:403 Forbidden”

    尝试其他镜子.

    错误:无法检索存储库的存储库元数据(repomd.xml):CentALT.请验证其路径,然后重试

当我检查EPEL(编辑说明:实际上是CentALT但为了清晰起见原文)url时,我在url中遇到了这个错误:

403 Forbidden - nginx

所以我决定改变EPEL来源.我浏览了http://howto.wikin.com/wiki/How_to_Delete_Centos_Repositories中的步骤以删除以前的存储库,当我做yum repolist得到这个:

Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.mirror.gtcomm.net
 * extras: centos.mirror.gtcomm.net
 * updates: centos.mirror.iweb.ca
http://centos.alt.ru/repository/centos/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"
Trying other mirror.
repo id         repo name                                                 status
CentALT         CentALT Packages for Enterprise Linux 6 - x86_64          0
base            CentOS-6 - Base                                           0
extras          CentOS-6 - Extras                                         0
mariadb         MariaDB                                                   0
updates         CentOS-6 - Updates                                        0
repolist: 0

现在,当我想用​​这个命令安装EPEL存储库时:

sudo rpm -Uvh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

仍然收到此错误:

检索http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

    准备…… ############################################# 100% ]

    包epel-release-6-8.noarch已经安装

如何安装EPEL repo?

要重新安装EPEL存储库,请为该存储库的.rpm重新安装yum.

yum reinstall 'http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm'
0

精彩评论

暂无评论...
验证码 换一张
取 消