运维开发网

如何在centos 6.9上安装docker-ce 17?

运维开发网 https://www.qedev.com 2020-05-08 17:29 出处:网络 作者:运维开发网整理
我目前正在尝试在centOS 6.9服务器上安装docker-ce 17,但是,当运行yum install docker-ce时,我收到以下错误:
我目前正在尝试在centOS 6.9服务器上安装docker-ce 17,但是,当运行yum install docker-ce时,我收到以下错误:

Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: systemd-units
Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: libseccomp.so.2()(64bit)
Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: libsystemd.so.0()(64bit)
Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: container-seLinux >= 2.9
Error: Package: docker-ce-17.06.1.ce-1.el7.centos.x86_64 (docker-ce-stable)
          Requires: libsystemd.so.0(LIBSYSTEMD_209)(64bit)

如果我用跳过的标志运行它我仍然得到相同的消息,

有没有人知道这方面的方法?

你需要钉住版本:

$yum install --setopt=obsoletes=0 \
   docker-ce-17.03.2.ce-1.el7.centos.x86_64 \
   docker-ce-seLinux-17.03.2.ce-1.el7.centos.noarch # on a new system with yum repo defined, forcing older version and ignoring obsoletes introduced by 17.06.0

更多细节在这里:

https://github.com/docker/for-Linux/issues/20

0

精彩评论

暂无评论...
验证码 换一张
取 消