运维开发网

centos – yum更新整个版本但限制为先前版本

运维开发网 https://www.qedev.com 2020-05-08 11:31 出处:网络 作者:运维开发网整理
我们需要更新yum更新,但我们希望保留一个版本.例如,我们有CentOS 6.2,并希望转向6.3.默认情况下,yum update看起来会安装6.4.
我们需要更新yum更新,但我们希望保留一个版本.例如,我们有CentOS 6.2,并希望转向6.3.默认情况下,yum update看起来会安装6.4.

在RedHat上,这可以通过订阅管理器完成.但是,由于订阅管理器是not available on CentOS,因此无法使用.

进入/etc/yum.repos.d/,仔细查看那里的所有文件.

对于指向CentOS存储库的每个文件,通过设置enabled = 0禁用它,并制作一个指向vault.centos.org上的CentOS 6.3 repo目录的副本.具有“repodata”子目录的任何目录都可用作yum存储库目录.

你可能至少想要:

[centos63]
name=CentOS 6.3 - $basearch
baseurl=http://vault.centos.org/6.3/os/$basearch
enabled=1
cost=1000

[centos63-updates]
name=CentOS 6.3 Updates - $basearch
baseurl=http://vault.centos.org/6.3/updates/$basearch
enabled=1
cost=1000

请注意,自CentOS 6.4发布以来,您不会获得任何安全更新.如果您安装了yum-plugin-security模块,您可以使用yum –enablerepo = centos –security update-minimal之类的命令来引入安全更新,但我还没有检查过,甚至没有验证了yum存储库名称.

0

精彩评论

暂无评论...
验证码 换一张
取 消