运维开发网

Spring Framework 5.3 正式 GA,维护至 2024 年

运维开发网 https://www.qedev.com 2021-05-15 11:53 出处:51CTO 作者:mob604756fb8908
Spring Framework 5.3 正式 GA,维护至 2024 年,mob604756fb8908的博客原创的Java文章。

喜欢就关注我们吧!

Spring Framework 5.3 已正式 GA。

Spring Framework 5.3 对 JDK 版本的要求为 JDK 8 或更高版本,尤其支持最新的 JDK 15,例如对 record class 的绑定支持。作为 5.x 的最后一个功能分支,5.3.x 系列为扩展支持做了准备,包括计划于明年发布的 JDK 17 LTS。

Spring Boot 2.4 和将于明年发布的 Spring Boot 2.5 版本都基于 Spring Framework 5.3.x,Spring Framework 5.3.x 还为 GraalVM 上的 Spring 原生可执行文件提供孵化支持。

此版本在 spring-r2dbc 模块增加了核心 R2DBC 支持,以作为 Spring Data R2DBC 基础,同时引入 JdbcTemplate 的查询结果流。新版本还为带有 JSON 负载的 Web 和消息传递端点提供了 Kotlin 多平台序列化支持,并利用新的 RSocketClient 和暴露负载平衡以支持 RSocket 1.1。

Spring MVC 用户可以通过 PathPattern 解析获得更好的性能(详情查看博客文章)。对于测试场景,官方为 MockMvc 提供了统一的 API 以及完整的 HTTP 测试,MockMvc 还附带了修订后的 Kotlin DSL。在 WebFlux 方面,现在包含了一个用于多部分请求的完全反应式消息读取器,以及一个用于 Apache Http Components 5 的 WebClient 连接器。

开发团队推荐所有使用 5.x 和 4.x 的用户升级至 Spring Framework 5.3,因为这是稳定、未来会提供支持和维护且可用于生产环境的分支,目前计划的维护周期将延长至 2024 年。同样是长期支持版本的 4.3.x 系列即将结束维护(2020年12月)。

0

精彩评论

暂无评论...
验证码 换一张
取 消