运维开发网

好用!解决maven包冲突的插件

运维开发网 https://www.qedev.com 2020-12-25 23:39 出处:网络 作者: mysoul
前言 在日常开发的过程中,经常会遇到找不到类文件的异常,但是这个类的的确确存在项目中,这称之为包的依赖冲突问题。

前言

在日常开发的过程中,经常会遇到找不到类文件的异常,但是这个类的的确确存在项目中,这称之为包的依赖冲突问题。

冲突问题

示例项目引入了两个fastjson.jar版本,分别为

fastjson:1.2.28

fastjson:1.2.3

例如,当我们项目中要用到1.2.28总的类,例如A类,但是在新的版本中,这个类被去除,但是调配的时候发现这个包存在,到底是那个包呢。

这里安利一款插件,使用该插件,可以直接一键完美解决掉idea中的maven冲突问题。

安利插件

这里安利的插件名称为 maven helper

解决问题

第一步

安装插件

好用!解决maven包冲突的插件

第二步

在安装完成以后,在pom文件下方会出现这个东西

好用!解决maven包冲突的插件

第三步

点进去会进入类似于eclipse界面的

好用!解决maven包冲突的插件

第四步

选择选项conficts,这个选项的意思是筛选所有冲突的包

好用!解决maven包冲突的插件

第五步

这里的例子冲突的是fastjson如下图所示

好用!解决maven包冲突的插件

第六步

选择右键,exclude,去除其相关的版本。即可自动去除。

好用!解决maven包冲突的插件

以上就是好用!解决maven包冲突的插件的详细内容,更多关于解决maven包冲突的资料请关注我们其它相关文章!

0

精彩评论

暂无评论...
验证码 换一张
取 消