运维开发网

三层交换实验

运维开发网 https://www.qedev.com 2020-11-30 11:48 出处:51CTO 作者:小岑的博客
实验需求:SW1为VTP的服务器模式,所有交换机上应该存在VLAN10 ,VLAN20 ,VLAN 30 ,这3个VLAN。要确保SW1能够成为这3个VLAN的根网桥.将R1划分到VLAN 10里去,并且给R1的E0/2口配置IP:192.168.1.1 255.255.255.0 R2划分到VLAN 20里去,E0/2口IP为:192.168.2.1 255.255.255.0.要求配置所有的交

实验需求:

SW1为VTP的服务器模式,所有交换机上应该存在VLAN10 ,VLAN20 ,VLAN 30 ,这3个VLAN。要确保SW1能够成为这3个VLAN的根网桥.

将R1划分到VLAN 10里去,并且给R1的E0/2口配置IP:192.168.1.1 255.255.255.0 R2划分到VLAN 20里去,E0/2口IP为:192.168.2.1 255.255.255.0.

要求配置所有的交换机能够实现R1和R2的正常通信.

禁止在路由器上配置任何路由协议.

若R1和R2直接连接在3层交换机SW1上如何进行配置.请自己更改拓扑完成此配置.

第一个和第二个需求的解法

SW1上的配置:

SW1(config)#no ip do lo //关闭域名解析

SW1(config)#lin con 0

SW1(config-line)#no exec-timeout //关闭超时,当使用模拟器的时候这个命令必须敲

SW1(config-line)#logging synchronous //关闭日志同步

SW1(config-line)#exit

SW1(config)#interface f0/12

SW1(config-if)#switchport mode trunk //F0/12设置为trunk接口

SW1(config-if)#exit

SW1(config)#

SW1(config)#exit

SW1#vlan database

SW1(vlan)#vtp domain cisco //配置VTP域名为cisco

SW1(vlan)#vtp server //模式服务器模式

SW1(vlan)#vlan 10 name vlan-10 //创建VLAN 10 VLAN 20 VLAN 30

SW1(vlan)#vlan 20 name vlan-20

SW1(vlan)#vlan 30 name vlan-30

SW1(vlan)#exit

SW2上的配置:

SW2(config)#no ip do lo

SW2(config)#lin con 0

SW2(config-line)#no exec-timeout

SW2(config-line)#logging synchronous

SW2(config-line)#exit

SW2(config)#interface f0/12

SW2(config-if)#switchport mode trunk

SW2(config-if)#exit

SW2#vlan database

SW2(vlan)#vtp client

SW2(vlan)#vtp domain cisco

SW2(vlan)#exit

SW2#configure terminal

SW2(config)#interface f0/1

SW2(config-if)#switchport access vlan 10 //将接口F0/1划分到VLAN 10表示路由器R1属于VLAN 10

SW2(config-if)#int f0/2

SW2(config-if)#switchport access vlan 20 //接口F0/2划分到VLAN 20里去

SW2(config-if)#

R1上的配置:

R1(config)#no ip do lo

R1(config)#lin con 0

R1(config-line)#no exec-t

R1(config-line)#no exec-timeout

R1(config-line)#logging synchronous

R1(config-line)#exit

R1(config)#no ip routing //关闭路由器的路由功能,需要注意如果希望将路由器模拟成PC的话需要关闭路由配置网管,并且路由和网管只能存在一个,如果路由存在的情况下,网管配置了是不会生效的。

R1(config)#interface e0/2

R1(config-if)#no shutdown

R1(config-if)#ip add 192.168.1.1 255.255.255.0

R1(config)#ip default-gateway 192.168.1.254 //配置一个网管

R1(config)#

R2上的配置:

R2(config)#no ip do lo

R2(config)#lin con 0

R2(config-line)#no exec-timeout

R2(config-line)#logging synchronous

R2(config)#no ip routing

R2(config)#int e0/2

R2(config-if)#no shutdown

R2(config-if)#ip add 192.168.2.1 255.255.255.0

R2(config)#ip default-gateway 192.168.2.254

R2(config)#

上面的配置命令是完成第一和第二个需求,如果说希望实现2个不同的vlan之间能够进行需要在我们的3层交换机上,针对VLAN 起IP地址就可以了。

SW1#configure terminal

SW1(config)#ip routing

SW1(config)#interface vlan 10

SW1(config-if)#ip add 192.168.1.254 255.255.255.0 //为VLAN 10去配置IP地址,需要注意的是地址应该和VLAN 10的PC保持在同一网段。并且VLAN 10接口我们称为SVI接口,他是一个逻辑上的接口可以接受所有VLAN 10的数据。

SW1(config-if)#int vlan 20

SW1(config-if)#ip add 192.168.2.254 255.255.255.0 //为VLAN 20配置地址

SW1(config-if)#exit

做完以后请使用PING命令进行测试啊。关于DHCP的配置这里不演示了,同学们自己总结我上课所演示的实验。

说下第5步如何去做,第5步和前面的做发很相似,在SW1上做VLAN的划分以后,并且给VLAN配置上IP地址以后就可以实现VLAN之间的相互通信。

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号