运维开发网

objective-C语言 使用Xcode 4编译libogg

运维开发网 https://www.qedev.com 2020-03-05 15:26 出处:网络 作者:运维开发网整理
我刚刚从 http://www.xiph.org/downloads/下载了libogg(http://downloads.xiph.org/releases/ogg/libogg-1.3.0.tar.gz),我现在正在尝试编译该包中提供的Ogg.xcodeproj项目.当我尝试构建时,我收到以下错误: The run destination My Mac 64-bit is not valid
我刚刚从 http://www.xiph.org/downloads/下载了libogg(http://downloads.xiph.org/releases/ogg/libogg-1.3.0.tar.gz),我现在正在尝试编译该包中提供的Ogg.xcodeproj项目.当我尝试构建时,我收到以下错误:

The run destination My Mac 64-bit is not valid for Running the scheme ‘Ogg’.

The scheme ‘Ogg’ contains no buildables that can be built for the SDKs supported by the run destination My Mac 64-bit. Make sure your targets all specify SDKs that are supported by this version of Xcode.

如果我尝试构建静态库而不是框架,我会收到类似的错误:

The run destination My Mac 64-bit is not valid for Running the scheme ‘libogg (static)’.

The scheme ‘libogg (static)’ contains no buildables that can be built for the SDKs supported by the run destination My Mac 64-bit. Make sure your targets all specify SDKs that are supported by this version of Xcode.

再次,这只是第一次在Xcode 4.3.2中打开项目并尝试构建.我根本没有对项目文件进行任何更改.

任何人都可以指向我的解决方案,以使其编译?

在我的例子中,Xcode项目链接旧架构上的旧SDK(OS X 10.5 PPC,而我有OS X 10.8 Mountain Lion x64).

要在Xcode 5中修复此问题,请在Xcode中选择顶级项目(项目文件夹窗格中最顶层的节点,蓝色的“A”图标),然后选择Project.将架构更改为适合您当前系统的内容,例如Build Architecture of Build机器,并将Base SDK更改为当前安装在Xcode环境中的SDK,例如OS X 10.8.

这是我的项目的屏幕截图,可以帮助您找到这些设置(按照突出显示的部分:kisshelper> kisshelper>体系结构):

0

精彩评论

暂无评论...
验证码 换一张
取 消