运维开发网

ruby-on-rails – 哪个Ruby on Rails与哪个Ruby版本兼容?

运维开发网 https://www.qedev.com 2020-08-13 12:14 出处:网络 作者:运维开发网整理
我有一个旧的2.1.1 Ruby on Rails应用程序,系统升级为使用Ruby 1.8.7.它最初使用1.8.5左右. 我想出于性能原因将它升级到Ruby 1.9.x,也可能升级到更新的Ruby on Rails. 我找不到任何简单的不同Ruby版本和Ruby on Rails版本之间的兼容性图表. 2.1.1将与Ruby 1.9.x一起使用吗?如果没有,我需要在多长时间内升级它,以及我可能会
我有一个旧的2.1.1 Ruby on Rails应用程序,系统升级为使用Ruby 1.8.7.它最初使用1.8.5左右.

我想出于性能原因将它升级到Ruby 1.9.x,也可能升级到更新的Ruby on Rails.

我找不到任何简单的不同Ruby版本和Ruby on Rails版本之间的兼容性图表.

2.1.1将与Ruby 1.9.x一起使用吗?如果没有,我需要在多长时间内升级它,以及我可能会遇到什么样的问题?我的应用程序对数据库层做了很复杂的事情,但其余部分相当简单.

这是一个老问题,但是自3.0以来Rails的稳定分支使用travis-ci进行自动化测试,并且rails针对某个版本的ruby进行测试这一事实很好地表明它应该适用于该版本的ruby.

rails分支测试的ruby版本列表如下:

Rails 3.0

> 1.8.7

> 1.9.2

> 1.9.3

Rails 3.1

> 1.8.7

> 1.9.2

> 1.9.3

Rails 3.2

> 1.8.7

> 1.9.2

> 1.9.3

> 2.0.0

> 2.1.8

> 2.2.6

> 2.3.3

Rails 4.0

> 1.9.3

> 2.0.0

> 2.1

> 2.2

Rails 4.1

> 1.9.3

> 2.0.0

> 2.1

> 2.2.4

> 2.3.0

Rails 4.2

> 1.9.3

> 2.0.0-p648

> 2.1.10

> 2.2.10

> 2.3.8

> 2.4.5

Rails 5.0

> 2.2.10

> 2.3.8

> 2.4.5

Rails 5.1

> 2.2.10

> 2.3.7

> 2.4.4

> 2.5.1

Rails 5.2

> 2.2.10

> 2.3.7

> 2.4.4

> 2.5.1

Rails 6.0

> 2.5.3

> 2.6.0

(自https://www.hmallett.co.uk/2018/08/ruby-and-ruby-on-rails-version-compatibility/起)

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号