运维开发网

java项目jar包与jdk的版本不兼容的问题解决

运维开发网 https://www.qedev.com 2020-08-07 13:42 出处:网络 作者: 不良帅~
这篇文章主要介绍了java项目jar包与jdk的版本不兼容的问题解决,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友可以参考下

这篇文章主要介绍了java项目jar包与jdk的版本不兼容的问题解决,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友可以参考下

在我们搭建框架或者引入jar包是,总是会因为版本不统一导致版本兼容问题,而且错误还不好找,

今天就遇到了一个问题Unsupported major.minor version 52.0并记录下解决方案

java项目jar包与jdk的版本不兼容的问题解决

错误原因:

我当时使用的是jdk7,因为公司是传统行业,所以jdk的版本不是很到,而我现在需要搭建一套新的项目框架,我引入了一些最新的jar包

报了很多这种错误Unsupported major.minor version 52.0

解决方案:

1、修改jdk的版本从1.7修改为1.8(我所使用的方案)

java项目jar包与jdk的版本不兼容的问题解决

2、将导入的jar包的版本降低

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持我们。

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消

关注公众号