运维开发网

scala – libraryDependencies中的revisionId如何成为SBT 0.13中的最新版本?

运维开发网 https://www.qedev.com 2020-07-30 08:44 出处:网络 作者:运维开发网整理
如何将libraryDependencies设置的revisionId设置为SBT 0.13中的最新可用版本.我使用“*”但似乎没有用,例如: "org.eclipse.jetty" % "jetty-webapp" % "*" SBT使用Ivy进行依赖性解析,因此它支持Ivy的动态修订语法: > 9.0.将匹配任何版本,如9.0.0或9.0.7, > latest.release将匹配最新版本,
如何将libraryDependencies设置的revisionId设置为SBT 0.13中的最新可用版本.我使用“*”但似乎没有用,例如:

"org.eclipse.jetty" % "jetty-webapp" % "*"
SBT使用Ivy进行依赖性解析,因此它支持Ivy的动态修订语法:

> 9.0.将匹配任何版本,如9.0.0或9.0.7,

> latest.release将匹配最新版本,

> [9.0,)匹配大于或等于9.0的所有版本,例如9.1.​​0,

> [9.0,9.1 [匹配所有版本大于或等于9.0且严格低于9.1,

>等等……:Ivy dynamic revision syntax

默认情况下,SBT将选择范围内的最新可用修订版,即使在依赖性冲突的情况下也是如此,但是这是can be customized.

0

精彩评论

暂无评论...
验证码 换一张
取 消