运维开发网
广告位招商联系QQ:123077622
 
广告位招商联系QQ:123077622

Docker镜像apt-get提示:E: Unable to locate package vim

运维开发网 https://www.qedev.com 2021-04-26 10:33 出处:51CTO 作者:80民工
很多次在使用docker镜像时,想使用个vim命令,提示命令不可用。于是想着安装一下就行,结果apt-get提示:E: Unable to locate package vim直接apt-get update之后再次安装

很多次在使用docker镜像时,想使用个vim命令,提示命令不可用。

于是想着安装一下就行,结果apt-get提示:

E: Unable to locate package vim

直接apt-get update之后再次安装,也还是提示这个,有点烦人。

于是只能增加一条源地址到/etc/apt/sources.list文件中。

# cat /etc/apt/sources.listdeb http://deb.debian.org/debian stretch main
deb http://security.debian.org/debian-security stretch/updates main
deb http://deb.debian.org/debian stretch-updates main

# echo deb http://archive.ubuntu.com/ubuntu/trusty main universe restricted multiverse >> /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu/trusty main universe restricted multiverse这个地址添加到/etc/apt/sources.list文件中,然后apt-get update更新完之后安装就可以了。

扫码领视频副本.gif

0

精彩评论

暂无评论...
验证码 换一张
取 消