运维开发网

docker指定版本安装

运维开发网 https://www.qedev.com 2020-07-15 09:51 出处:网络 作者:运维开发网整理
如果已安装过docker,彻底删除docker 非docker-ce版本卸载   docker-ce版本卸载 列出docker安装过的相关包 yum list installed | grep docker   删除相关安装包   yum -y remove docker-ce-cli.x86_64   安装指定版本docker 安装所需工具和配置 yum install -y yum-utils

如果已安装过docker,彻底删除docker

非docker-ce版本卸载

docker指定版本安装

 

docker-ce版本卸载

列出docker安装过的相关包

yum list installed | grep docker

 

删除相关安装包

 

yum -y remove docker-ce-cli.x86_64

 

安装指定版本docker

安装所需工具和配置

yum install -y yum-utils

yum-config-manager --add-repo https://mirrors.aliyun.com/docker-ce/Linux/centos/docker-ce.repo

查看版本

yum list docker-ce --showduplicates|sort -r

 

可以看到

docker指定版本安装

 

 

 

选择指定版本安装

安装(一路选择y进行安装)

yum install docker-ce-18.06.1.ce-3.el7 docker-ce-seLinux-18.06.1.ce-3.el7

 

同时启动并设置开机自启

 

systemctl enable docker && sudo systemctl start docker

 

最后,测试一下

 

docker --version

 

输出

Docker version 18.06.1-ce, build e68fc7a

安装成功

0

精彩评论

暂无评论...
验证码 换一张
取 消