运维开发网

kubernetes安装报错:Error: docker-ce-cli conflicts with

运维开发网 https://www.qedev.com 2020-06-13 18:39 出处:网络 作者:运维开发网整理
Centos7.6上yum安装kubernetes报错: Error: docker-ce-cli conflicts with 2:docker-1.13.1-91.git07f3374.el7.centos.x86_64 You could try using --skip-broken to work around the problem You could try running: rpm
Centos7.6上yum安装kubernetes报错:

Error: docker-ce-cli conflicts with 2:docker-1.13.1-91.git07f3374.el7.centos.x86_64

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

原因:yum安装kubernetes之前已经安装过docker,导致出现上面报错;

按照提供执行 rpm -Va --nofiles --nodigest 命令并没有作用,还是避免不了冲突;

解决方法:

卸载

1、查询安装过的包

yum list installed | grep docker

containerd.io.x86_64 1.2.4-3.1.el7 @docker-ce-edge

docker-ce-cli.x86_64 1:18.09.3-3.el7 @docker-ce-edge

2、删除安装的软件包

yum -y remove docker-ce-cli.x86_64

yum -y remove containerd.io.x86_64

3、删除镜像/容器等

rm -rf /var/lib/docker

rm -rf /var/run/docker

安装yum install -y etcd kubernetes完美解决问题!

0

精彩评论

暂无评论...
验证码 换一张
取 消